Bug 183099 - Provides: perl(main)
Provides: perl(main)
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: Sprog (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Gavin Henry
Fedora Extras Quality Assurance
:
Depends On:
Blocks: FE6Target
  Show dependency treegraph
 
Reported: 2006-02-26 02:54 EST by Ralf Corsepius
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version: 0.14-11.fc5
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-02-20 06:11:16 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ralf Corsepius 2006-02-26 02:54:42 EST
Description of problem:
The Sprog package "Provides: perl(main)".

This is a packaging bug. It shouldn't do so.

Version-Release number of selected component (if applicable):
0.14-7

Expected results:
Not providing perl(main).

Additional info:
You need to filter perl(main) from this package's provides.

Check the perl-HTML-Tree package's spec for one way to achieve this.
Comment 1 Gavin Henry 2006-02-26 04:31:17 EST
Shouldn't that be handled by the requires perl script?

It should know that this is not the perl RPM.

If it doesn't it should be patched.

Gavin.

Comment 2 Ralf Corsepius 2006-02-26 06:14:30 EST
(In reply to comment #1)
> Shouldn't that be handled by the requires perl script?
Yes, this is a bug in rpm ...
 
> It should know that this is not the perl RPM. 
> If it doesn't it should be patched.
Agreed, but this doesn't help us NOW. Your package provides bogus provides, so
you can't avoid working around this issue.
Comment 3 Ville Skyttä 2006-02-26 07:03:48 EST
(In reply to comment #2)
> (In reply to comment #1)
> > Shouldn't that be handled by the requires perl script?
> Yes, this is a bug in rpm ...

...which is fixed in rpm >= 4.4.2-12.  A simple rebuild with such a version will
fix it, and in fact Sprog-0.14-7.fc5 no longer provides perl(main).

$ rpm -q Sprog
Sprog-0.14-7.fc5
$ rpm -q --provides Sprog | grep main
$

> Agreed, but this doesn't help us NOW.

It does for devel.

> Your package provides bogus provides, so
> you can't avoid working around this issue.

This workaround is needed in <= FC4 only.
Comment 4 Ralf Corsepius 2006-02-26 07:08:57 EST
(In reply to comment #3)
> (In reply to comment #2)
> > (In reply to comment #1)
> > > Shouldn't that be handled by the requires perl script?
> > Yes, this is a bug in rpm ...

> > Your package provides bogus provides, so
> > you can't avoid working around this issue.
> 
> This workaround is needed in <= FC4 only.

... or somebody will have to fix rpm for <= FC4, too.
 
Comment 5 Gavin Henry 2006-02-26 09:44:49 EST
I'll do the workaround for FC-4 then ;-)

I'll read perl-HTML-Tree, like Ralf suggested.

Thanks,

Gavin.
Comment 6 Gavin Henry 2006-02-26 10:02:15 EST
I can't find the perl-HTML-Tree SRPM in either the FC-4 tree or Developement?

Any pointers?

Gavin.
Comment 7 Ville Skyttä 2006-02-26 10:09:21 EST
It's in Extras.
Comment 8 Gavin Henry 2006-02-26 10:44:47 EST
Doh!
Comment 9 Gavin Henry 2006-02-26 18:09:40 EST
Done and built.
Comment 10 Ralf Corsepius 2007-02-20 06:11:16 EST
The PR seems obsolete since a long time, closing ...

Note You need to log in before you can comment on or make changes to this bug.