Bug 183102 - Dual booting shifts time forward despite correct settings.
Dual booting shifts time forward despite correct settings.
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: adjtimex (Show other bugs)
5
ppc64 Linux
medium Severity medium
: ---
: ---
Assigned To: Miroslav Lichvar
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-02-26 04:07 EST by Brian Durant
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-03-06 08:05:37 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Brian Durant 2006-02-26 04:07:08 EST
Description of problem:

Dual booting into FC5 test 3 and then back into OS X (10.4.5) shifts time
forward by one hour despite clock time, time zone and no UTC having been set
correctly in both platforms.

Version-Release number of selected component (if applicable):

Unknown.

How reproducible:

Everytime.

Steps to Reproduce:
1. Boot into OS X, make sure the time is set correctly.
2. Boot into FC5 test 3    ".
3. Boot into OS X and      ".
  
Actual results:

Time shifts forward by one hour.

Expected results:

Time remains the same

Additional info:
Comment 1 Miroslav Lichvar 2006-02-27 05:05:25 EST
Ok, I'm not sure where the problem might be. I would like to ask you few
questions before we can get any further.

Is the shift exactly one hour?

Will the error keep increasing if you repeat the steps to reproduce without
correcting time in OS X? Or it stays at one hour?

Did you enable ntp service in FC?
Comment 2 Brian Durant 2006-02-28 06:19:21 EST
Yes, exactly one hour.

Error stays the same, regardless of repeated reboots between FC and OS X.

Yes, I enabled ntp in FC. The time is shown correctly in FC.
Comment 3 Miroslav Lichvar 2006-02-28 08:47:32 EST
Looks like the systems differ in the way the clock is stored. What happens when
you set both systems to store time in UTC?
Comment 4 Brian Durant 2006-02-28 08:52:38 EST
I don't see any way to do that in OS X.
Comment 5 Karel Zak 2006-02-28 09:16:32 EST
Please, check your (on Fedora) /etc/sysconfig/clock. You can try to use
UTC=false, so your both OS will be use localtime. 

For more details see "man hwclock": 

... Indicates  that  the  Hardware  Clock is kept in Coordinated Universal Time
or local time, respectively.  It is your choice whether to keep your clock in
UTC or local time,  but nothing in the clock tells which you've chosen.
                 ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
It means all your system should save to HW clock same time.
Comment 6 Brian Durant 2006-03-01 13:22:53 EST
UTC=false
ARC=false

Were already set.
Comment 7 Miroslav Lichvar 2006-03-02 04:52:28 EST
Brian, could you look at:

http://lists.debian.org/debian-powerpc/2003/05/msg00242.html
http://www.cs.rpi.edu/~kulkam/misc.html

It looks like you will have to reset an offset that is stored in nvram.
Comment 8 Brian Durant 2006-03-02 14:12:35 EST
Weird. After I accessed /etc/sysconfig/clock, I no longer have a problem. I
didn't make any changes in the file at all. One other thing I did was to check
the clock preferences in the panel, but I didn't make any changes there either.

Note You need to log in before you can comment on or make changes to this bug.