Bug 183105 - lablgtk2 needs to be recompiled for updated ocaml package
lablgtk2 needs to be recompiled for updated ocaml package
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: lablgtk (Show other bugs)
4
x86_64 Linux
medium Severity high
: ---
: ---
Assigned To: Gérard Milmeister
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-02-26 06:52 EST by Dom T
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-27 10:52:43 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dom T 2006-02-26 06:52:55 EST
Description of problem: 
Unable to compile ocaml programs that use the lablgtk2 lib. 
Also running the lablgtk2 top level fails. 
 
Version-Release number of selected component (if applicable): 
ocaml-3.09.1-1.fc4 
lablgtk-2.6.0-1.fc4 
 
 
How reproducible: 
Always 
 
 
Steps to Reproduce: 
1. lablgtk2 
or 
2. ocamlc -g -w s -I +lablgtk2 lablgtk.cma gtkInit.cmo simple.ml -o simple 
where simple can be replaced by any source file using including examples. 
   
Actual results: 
The files /usr/lib64/ocaml/lablgtk2/lablgtk.cma 
and /usr/bin/ocaml 
disagree over interface Printf 
 
 
Expected results: 
No output, just an executable, or interactive toplevel. 
 
Additional info: 
The lablgtk package needs to be rebuilt to reflect changes made to the ocaml 
package. 
I suspect that the upgrade from ocaml 3.09.0 to 3.09.1 involved changes to the 
Printf module.
Comment 1 Gérard Milmeister 2006-02-27 10:52:43 EST
labgl and lablgtk are currently being rebuild.

Note You need to log in before you can comment on or make changes to this bug.