Bug 1831108 - Error VM Import status not visible in VMs list
Summary: Error VM Import status not visible in VMs list
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Container Native Virtualization (CNV)
Classification: Red Hat
Component: V2V
Version: 2.4.0
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: 2.4.0
Assignee: Filip Krepinsky
QA Contact: Ilanit Stein
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-05-04 16:25 UTC by Filip Krepinsky
Modified: 2020-07-13 17:35 UTC (History)
6 users (show)

Fixed In Version: v2v 2.4.0, OCP 4.5
Doc Type: No Doc Update
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-07-13 17:34:48 UTC
Target Upstream Version:
istein: needinfo+
istein: needinfo+


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift console pull 5282 0 None closed Bug 1831108: show all failed VMImports 2020-06-29 11:33:33 UTC
Red Hat Product Errata RHBA-2020:2409 0 None None None 2020-07-13 17:35:11 UTC

Description Filip Krepinsky 2020-05-04 16:25:08 UTC
How reproducible:
50% depending on the vm-import CR generated name


Steps to Reproduce:
1. import VM which succeeds in importing
2. delete that VM
3. import VM which fails to import (in validating phase)
4. failed VM is not visible in the VM's list


Expected results:
Import is shown every time

Comment 1 Filip Krepinsky 2020-05-04 16:26:14 UTC
* these VMs must have a same name

Comment 5 Ilanit Stein 2020-06-09 13:24:59 UTC
Verified on CNV-2.4
Was tested with two parallel imports of same source VM.
The second VM import failed on disk locked Import Error, as expected,
and it's VM import resource was listed in the VMs view.

Comment 6 Ilanit Stein 2020-06-09 13:25:53 UTC
Verified on CNV-2.4
Was tested with two parallel imports of same source VM.
The second VM import failed on disk locked Import Error, as expected,
and it's VM import resource was listed in the VMs view.

Comment 8 errata-xmlrpc 2020-07-13 17:34:48 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:2409


Note You need to log in before you can comment on or make changes to this bug.