Bug 183112 - PATCH: sound does not work on PPC
PATCH: sound does not work on PPC
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: allegro (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jindrich Novy
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-02-26 08:16 EST by Hans de Goede
Modified: 2013-07-02 19:14 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-27 04:55:41 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
PATCH fixing sound on PPC (407 bytes, patch)
2006-02-26 08:16 EST, Hans de Goede
no flags Details | Diff

  None (edit)
Description Hans de Goede 2006-02-26 08:16:59 EST
I'm the maintainer of several allegro using packages in extras, as I'm currently
working on a new package about which I had some doubts if it would work on PPC I
asked on the list if some PPC users could test it. one PPC user was kind enough
todo so. This tested resulted in the finding of a endianness bug in allegro.

More specificly in the digital audio alsa driver of allegro, which is the
default driver used by allegro, thus an error in this driver normally results in
no sound being available at all. The tester didn't have any sound with lacewing,
overgod and the game he was testing for me.

The attached patch fixes this endianness bug in allegro. The problem is that it
first sets format to NE (Native Endian)* and then checks if format is either 8
bit or LE (Little Endian) which although it works fine on LE machines will of
course fail on BE.

* unless 8 bit sound has been specified in allegrorc .
Comment 1 Hans de Goede 2006-02-26 08:16:59 EST
Created attachment 125276 [details]
PATCH fixing sound on PPC
Comment 2 Hans de Goede 2006-02-26 08:35:06 EST
p.s.

I also send this upstream.
Comment 3 Hans de Goede 2006-02-26 14:19:54 EST
p.s. 2

Since I'm currently doing a lot of packaging / development with allegro it might
be an idea if we experimented with shared package maintainer ship. This concept
has been mentioned on f-e-l some times before, but has afaik never been tried.

This would reduce work for both of us, since before I send any patches to you I
first do a local testbuild in a local modified version of the cvs devel-branch,
so it is less work for me if they turn out ok to fix the release, add a
changelog entry to the spec and push the changes then it is to explain the patch
in bugzilla, and it would save you the time of downloading, reviewing and
integrating the patches.

If you agree, then I'll add myself to the allegro bugs CC-list in owners.list,
and we must find a way to not step on each others toes (cvs-conflicts) while
working on allegro. This could be a simple as sending a mail when you start
working (basicly an advisory lock :) and sending another one when done.
Comment 4 Jindrich Novy 2006-02-27 03:23:36 EST
I have nothing against cooperation so I like the idea of shared maintainership.
The most of the patches related to allegro come from you anyway, so feel free to
add yourself to owners.list ;)
Comment 5 Hans de Goede 2006-02-27 03:25:30 EST
Will do, to avoid collisions, shall I commit and push this and the lib64 patch
or will you?
Comment 6 Jindrich Novy 2006-02-27 03:30:02 EST
Yes, feel free to do it. I'll try to look at bug 183033 at the time.
Comment 7 Hans de Goede 2006-02-27 04:55:41 EST
Committed to CVS and build requested
Comment 8 Hans de Goede 2006-02-27 04:58:36 EST
Hmm, guess it would have been better to not tag and build concidering you're
progressing nicely on bug 183033, I'll try to think of things like this the next
time.

Note You need to log in before you can comment on or make changes to this bug.