Bug 1831240 - Avoid multiple rerendering of the overview components added via plugins
Summary: Avoid multiple rerendering of the overview components added via plugins
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Dev Console
Version: 4.5
Hardware: All
OS: All
unspecified
high
Target Milestone: ---
: 4.5.0
Assignee: Karthik Jeeyar
QA Contact: Gajanan More
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-05-04 18:11 UTC by Karthik Jeeyar
Modified: 2020-07-13 17:35 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-07-13 17:34:48 UTC
Target Upstream Version:


Attachments (Terms of Use)
pipeline-multiple-mounting (1.79 MB, image/gif)
2020-05-04 18:11 UTC, Karthik Jeeyar
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Github openshift console pull 5284 0 None closed Bug 1831240: Avoid multiple rerendering of tab components registered via plugin 2020-06-24 01:36:19 UTC
Red Hat Product Errata RHBA-2020:2409 0 None None None 2020-07-13 17:35:11 UTC

Description Karthik Jeeyar 2020-05-04 18:11:46 UTC
Created attachment 1684928 [details]
pipeline-multiple-mounting

Description of problem:
While using the PipelineOverview component through a plugin in the sidebar. It mounts and unmounts continuously. Plugin is being used in `resource-overview-page.tsx` and defined in dev-console `plugin.tsx`.


Version-Release number of selected component (if applicable):
4.5

How reproducible:
Always

Steps to Reproduce:
1. Go to topology page
2. click on a workload which has pipeline associated with it
3. Inspect the pipeline component in the browser

Actual results:
The pipeline section in the sidebar will re render continously.

Expected results:
The pipeline section in the sidebar should not be re created everytime.

Comment 3 spathak@redhat.com 2020-05-26 14:59:25 UTC
https://issues.redhat.com/browse/ODC-2122?focusedCommentId=14115750&page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel#comment-14115750

Validated on build version: 4.5.0-0.ci-2020-05-21-054511
Browser version: Firefox 73

Comment 4 errata-xmlrpc 2020-07-13 17:34:48 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:2409


Note You need to log in before you can comment on or make changes to this bug.