Bug 183133 - torcs needs a rebuild against new openal
torcs needs a rebuild against new openal
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: torcs (Show other bugs)
4
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Matthias Saou
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-02-26 14:34 EST by Alex Lancaster
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-28 23:37:04 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alex Lancaster 2006-02-26 14:34:40 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.12) Gecko/20060202 Galeon/2.0.0

Description of problem:
New openal breaks upgrade.

Version-Release number of selected component (if applicable):
torcs-1.2.4-1.fc4

How reproducible:
Always

Steps to Reproduce:
1. yum upgrade

  

Actual Results:  sudo yum upgrade
[...]

--> Running transaction check
--> Processing Dependency: libopenal.so.0 for package: torcs
--> Processing Dependency: libopenal.so.0 for package: scorched3d
--> Finished Dependency Resolution
Error: Missing Dependency: libopenal.so.0 is needed by package torcs
Error: Missing Dependency: libopenal.so.0 is needed by package scorched3d


Expected Results:  Upgrade should have worked.

Additional info:
Comment 1 Alex Lancaster 2006-02-26 14:37:14 EST
Andreas Bierfert (maintainer of openal) should co-ordinate his releases better
with the maintainers of dependent packages, before it reaches the end user.  It
seems a general problem with extras that maintainers are unaware of the
influences  their package updates have on other packages.  There really needs to
be some automated system that could notify them.
Comment 2 Alex Lancaster 2006-02-26 14:39:53 EST
See also bug #181134.
Comment 3 Alex Lancaster 2006-02-26 14:41:10 EST
(In reply to comment #2)
> See also bug #181134.

Sorry, wrong bug, should have been bug #183134.
Comment 4 Hans de Goede 2006-02-26 15:08:16 EST
Please don't rebuild yet see my comments in bug 181989, quoting from there:

"Erm,

This fix has the nice side affect of bumping the .so version, next time please
check for something like this before pushing a change. It might even be an idea
to issue an other update undoing this since the new .so version undoubtly means
that upstream plans on making abi changes, which means that we will have an
unstable abi for a while which will _not_ be caught by the .so versioning since
you're using CVS with no abi guarantees as such, hence its a bad idea to use CVS.

Also see bug 183133 and bug 183134 I'll but 183134 on hold untill I hear from
you and request the same for 183133 ."
Comment 5 joe 2006-02-27 11:32:18 EST
same problem - it also includes blender - and the libopenal would not let me yum
 update untill after I removed both. Besides the above I was able to get these
errors trying to run torcs from the command line - hope it helps:

 torcs
Visual Properties Report
------------------------
Compatibility mode, properties unknown.
OpenAL backend info:
  Vendor: OpenAL Community
  Renderer: Software
  Version: 1.1
  Available sources: 1024 or more
  Available buffers: 1024 or more
/usr/lib/torcs/torcs-bin: symbol lookup error:
/usr/lib/torcs/modules/graphic/ssggraph.so: undefined symbol: alutLoadWAVFile

This occured after I removed torcs and blender, updated my system, and
re-installed torcs and blender.
Comment 6 Alex Lancaster 2006-02-28 23:37:04 EST
openal has been backgraded back to the old .so version so a torcs upgrade is no
longer necessary.  Closing bug.
Comment 7 Alex Lancaster 2006-02-28 23:42:43 EST
(In reply to comment #5)
> same problem - it also includes blender - and the libopenal would not let me yum
>  update untill after I removed both. Besides the above I was able to get these
> errors trying to run torcs from the command line - hope it helps:
> 
>  torcs
> Visual Properties Report
> ------------------------
> Compatibility mode, properties unknown.
> OpenAL backend info:
>   Vendor: OpenAL Community
>   Renderer: Software
>   Version: 1.1
>   Available sources: 1024 or more
>   Available buffers: 1024 or more
> /usr/lib/torcs/torcs-bin: symbol lookup error:
> /usr/lib/torcs/modules/graphic/ssggraph.so: undefined symbol: alutLoadWAVFile
> 
> This occured after I removed torcs and blender, updated my system, and
> re-installed torcs and blender.

Hmm, I get the same error when I just about the start the game, but I think this
is a torcs bug, or torcs packaging bug not related to the openal problem.  So
probably should open a new bug on this.

Note You need to log in before you can comment on or make changes to this bug.