Bug 183137 - ipw2200 doesn't work
ipw2200 doesn't work
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
4
All Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-02-26 15:58 EST by David
Modified: 2015-01-04 17:25 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-06-26 10:58:37 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David 2006-02-26 15:58:26 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.12) Gecko/20060202 Fedora/1.0.7-1.2.fc4 Firefox/1.0.7

Description of problem:
no wireless, no sound, no battery status, no video.
unable to configure wireless, sound. 

ACPI: bus type pci registered
PCI: PCI BIOS revision 2.10 entry at 0xfd7ce, last bus=7
PCI: Using MMCONFIG
ACPI: Subsystem revision 20050902
    ACPI-0339: *** Error: Looking up [Z00A] in namespace, AE_NOT_FOUND
search_node c18cec40 start_node c18cec40 return_node 00000000

PCI: If a device

 doesn't work, try "pci=routeirq".  If it helps, post a report

eth0: RealTek RTL8139 at 0xf886e000, 00:16:36:0c:6c:14, IRQ 10
eth0:  Identified 8139 chip type 'RTL-8100B/8139D'
8139cp: 10/100 PCI Ethernet driver v1.2 (Mar 22, 2004)
ipw2200: Unknown symbol ieee80211_wx_get_encodeext
ipw2200: Unknown symbol ieee80211_wx_set_encode
ipw2200: Unknown symbol ieee80211_wx_get_encode
ipw2200: Unknown symbol ieee80211_txb_free
ipw2200: Unknown symbol ieee80211_wx_set_encodeext
ipw2200: Unknown symbol ieee80211_wx_get_scan
ipw2200: Unknown symbol escape_essid
ipw2200: Unknown symbol ieee80211_rx
ipw2200: Unknown symbol ieee80211_rx_mgt
ipw2200: Unknown symbol free_ieee80211
ipw2200: Unknown symbol alloc_ieee80211

application mixer_applet2 uses obsolete OSS audio interface
    ACPI-0339: *** Error: Looking up [Z00A] in namespace, AE_NOT_FOUND

rtl8129 device eth1 does not seem to be present, delaying initialization.

Command failed: /sbin/modprobe  rtl8129

Output:
FATAL: Module rtl8129 not found.

Copyright (C) 2004 Intel Corporation <jketreno@linux.intel.com>

FATAL: Error inserting ieee80211 

make -C /lib/modules/2.6.15-1.1831_FC4/build M=/usr/src/ieee80211-1.0.1 MODVERDIR=/usr/src/ieee80211-1.0.1 modules
make[1]: Entering directory `/usr/src/kernels/2.6.15-1.1831_FC4-i686'
make[1]: *** No rule to make target `modules'.  Stop.
make[1]: Leaving directory `/usr/src/kernels/2.6.15-1.1831_FC4-i686'
make: *** [modules] Error 2





Version-Release number of selected component (if applicable):
kernel 2.6.15-1.1831_FC4

How reproducible:
Always

Steps to Reproduce:
1. try to configure 
2.
3.
  

Additional info:

let me know if I can provide any aditional info.

Thanks David Sequoias
Comment 1 Phil Knirsch 2006-03-03 07:36:16 EST
That bug sounds more like a kernel problem, reassigning to the proper component.

Read ya, Phil
Comment 2 Dave Jones 2006-03-05 00:22:14 EST
does the wireless driver in 1833 work any better? 
(Building your own driver is unsupported, any issues you have with that you
should take to the driver maintainers)
Comment 3 David 2006-03-14 16:12:11 EST
Linux localhost.localdomain 2.6.15-1.1833_FC4 #1 Wed Mar 1 23:41:37 EST 2006 
i686 i686 i386 GNU/Linux

ACPI: Subsystem revision 20050902
    ACPI-0339: *** Error: Looking up [Z00A] in namespace, AE_NOT_FOUND
search_node c18dcc40 start_node c18dcc40 return_node 00000000

PCI: Using ACPI for IRQ routing
PCI: If a device doesn't work, try "pci=routeirq".  If it helps, post a report
PCI: Cannot allocate resource region 7 of bridge 0000:00:1c.0s

ipw2200: Intel(R) PRO/Wireless 2200/2915 Network Driver, git-1.0.8
ipw2200: Copyright(c) 2003-2005 Intel Corporation
ipw2200: Detected Intel PRO/Wireless 2200BG Network Connection
ipw2200: ipw-2.4-boot.fw load failed: Reason -2
ipw2200: Unable to load firmware: -2
ipw2200: failed to register network device
ipw2200: probe of 0000:06:04.0 failed with error -5

ieee80211_crypt: registered algorithm 'NULL'
ieee80211: 802.11 data/management/control stack, git-1.1.7
ieee80211: Copyright (C) 2004-2005 Intel Corporation <jketreno@linux.intel.com>
Comment 4 Jonathan M. Prigot 2006-05-21 20:42:43 EDT
I'm seeing the ipw-2.4-boot.fw load fail on FC5 as well.
Comment 5 Jonathan M. Prigot 2006-05-22 14:28:52 EDT
I found /lib/firmware empty. After I went to the Intel website, downloaded the
driver kit, and populated /lib/firmware, the card now loads and works fine. (Is
this due to RH/FC rejecting binary driver modules from inclusion?)
Comment 6 Thomas M Steenholdt 2006-06-20 15:39:49 EDT
ipw2200 version 1.1.3m and ieee80211 version 1.1.14 works very well for me. It's
clearly the best version of the ipw2200 driver i've tried so far.

NetworkManager works great with WPA-Personal encrypted networks with hidden SSID
as well as unencrypted wireless networks. That's all i've tried. It seems like
my frequent dropouts are gone or at least minimized in some way.
Comment 7 Dave Jones 2006-06-26 10:58:37 EDT
Note: With the latest 2.6.17 update, you must have the 3.0 firmware installed
from http://ipw2200.sf.net

The original problem in this bug should be fixed, so I'm closing this out.
If there are still any problems with this driver, please file a separate bug.

Thanks.

Note You need to log in before you can comment on or make changes to this bug.