This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 183151 - [PATCH] script to generate self-signed certificates does not work
[PATCH] script to generate self-signed certificates does not work
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: dovecot (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Tomas Janousek
:
Depends On:
Blocks: FC6Blocker
  Show dependency treegraph
 
Reported: 2006-02-26 19:47 EST by Mark Sobell
Modified: 2014-01-21 17:53 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-12-27 03:54:34 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
shows the errors in two cases of the problem (3.24 KB, text/plain)
2006-02-26 19:47 EST, Mark Sobell
no flags Details

  None (edit)
Description Mark Sobell 2006-02-26 19:47:02 EST
Description of problem:
The script at
/usr/share/doc/dovecot-1.0/examples/mkcert.sh
generates errors.

Version-Release number of selected component (if applicable):


How reproducible:
always

Steps to Reproduce:
1.sh /usr/share/doc/dovecot-1.0/examples/mkcert.sh
2.
3.
  
Actual results:
Various, depending on whether you set SSLDIR and which working directory you run
it from. See attached file.

I works properly if you set SSLDIR and cd to the proper directory:

# export SSLDIR=/etc/pki/dovecot
# cd /etc/pki/dovecot


Expected results:
Should run without errors when run without setting SSLDIR and when run from any
location.

Additional info:
Comment 1 Mark Sobell 2006-02-26 19:47:02 EST
Created attachment 125291 [details]
shows the errors in two cases of the problem
Comment 2 Chris Langlands 2006-09-15 01:11:41 EDT
the following seems to be all that's needed


--- /usr/share/doc/dovecot-1.0/examples/mkcert.sh.orig  2006-09-15
09:11:40.000000000 +0800
+++ /usr/share/doc/dovecot-1.0/examples/mkcert.sh       2006-09-15
09:28:22.000000000 +0800
@@ -4,8 +4,8 @@
 # Edit dovecot-openssl.cnf before running this.

 OPENSSL=${OPENSSL-openssl}
-SSLDIR=${SSLDIR-/etc/ssl}
-OPENSSLCONFIG=${OPENSSLCONFIG-dovecot-openssl.cnf}
+SSLDIR=${SSLDIR-/etc/pki/dovecot}
+OPENSSLCONFIG=${OPENSSLCONFIG-/etc/pki/dovecot/dovecot-openssl.cnf}

 CERTFILE=$SSLDIR/certs/dovecot.pem
 KEYFILE=$SSLDIR/private/dovecot.pem
Comment 3 Matthias Saou 2006-09-28 10:31:30 EDT
Ping? Petr, you seem to have updated to 1.0rc7 a few days ago. This quick patch
would have been a welcome change, as it fixes this issue and would allow to
close this FC6Blocker bug.
Comment 5 Petr Rockai 2006-10-04 06:45:05 EDT
Sorry, i must have overlooked this. I have no idea why it is a blocker though, 
it is just a documentation issue -- the script is installed 
under /usr/share/doc/. It does not affect functionality of the package in any 
way and self-signed certificates are generated by scriptlets anyway.

Either way, i have fixed this in CVS.
Comment 6 Tomas Janousek 2006-12-21 07:33:59 EST
Fixed in FC-5 CVS as well, will push update soon or later.
Comment 7 Fedora Update System 2006-12-23 14:14:06 EST
dovecot-1.0-0.beta8.3.fc5 has been pushed for fc5, which should resolve this issue.  If these problems are still present in this version, then please make note of it in this bug report.
Comment 8 Fedora Update System 2006-12-27 01:02:52 EST
dovecot-1.0-0.beta8.3.fc5 has been pushed for fc5, which should resolve this issue.  If these problems are still present in this version, then please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.