Bug 1831680 - Trying to create a hybrid network network after install should fail
Summary: Trying to create a hybrid network network after install should fail
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Networking
Version: 4.5
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: 4.5.0
Assignee: Jacob Tanenbaum
QA Contact: Anurag saxena
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-05-05 13:27 UTC by Jacob Tanenbaum
Modified: 2020-07-13 17:35 UTC (History)
0 users

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-07-13 17:35:00 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift cluster-network-operator pull 611 0 None closed Bug 1831680: Prevent patching the HybridOverlayConfig after install time 2021-01-13 14:54:58 UTC
Github openshift cluster-network-operator pull 628 0 None closed bug 1831680: Want to be able to enable hybrid networking only if HybridOverlayConfig is nil 2021-01-13 14:55:39 UTC
Red Hat Product Errata RHBA-2020:2409 0 None None None 2020-07-13 17:35:20 UTC

Description Jacob Tanenbaum 2020-05-05 13:27:41 UTC
Description of problem:

The requirements for hybrid networking has changed and it is no longer supported to start a hybrid network on a running cluster. Currently trying to patch the CNO to enable a hybrid network succeeds and it should fail.  

Version-Release number of selected component (if applicable):
4.5

How reproducible:

Everytime 

Steps to Reproduce:
1. Deploy an openshift cluster with OVNKubernetes 
2. patch the CNO to enable a hybrid network 
3. the patch operation succeeds 

Actual results:
The patch operation is allowed to happen

Expected results:
The patch operation should fail

Additional info:
Patch the CNO so the operator config looks like this 

apiVersion: operator.openshift.io/v1
kind: Network
metadata:
  creationTimestamp: null
  name: cluster
spec:
  clusterNetwork:
  - cidr: 10.128.0.0/14         <- must be the cluster network CIDR
    hostPrefix: 23
  externalIP:
    policy: {}
  networkType: OVNKubernetes
  serviceNetwork:
  - 172.30.0.0/16                <- must be the service network CIDR
  defaultNetwork:
    type: OVNKubernetes
    ovnKubernetesConfig:
      hybridOverlayConfig:
        hybridClusterNetwork:
        - cidr: 10.132.0.0/14    <- must not overlap cluster or service cidr    
          hostPrefix: 23

Comment 8 errata-xmlrpc 2020-07-13 17:35:00 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:2409


Note You need to log in before you can comment on or make changes to this bug.