Bug 1831735 - Clickable Resource Link in the start pipeline modal
Summary: Clickable Resource Link in the start pipeline modal
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Dev Console
Version: 4.5
Hardware: Unspecified
OS: Unspecified
high
medium
Target Milestone: ---
: 4.5.0
Assignee: Andrew Ballantyne
QA Contact: Gajanan More
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-05-05 14:31 UTC by Andrew Ballantyne
Modified: 2020-07-13 17:35 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-07-13 17:35:00 UTC
Target Upstream Version:


Attachments (Terms of Use)
Not Clickable Resource Link in the start pipeline modal (92.49 KB, image/png)
2020-05-14 23:54 UTC, spathak@redhat.com
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Github openshift console pull 5300 0 None closed Bug 1831735: Disable Pipeline Secret resource link 2020-06-24 01:40:47 UTC
Red Hat Product Errata RHBA-2020:2409 0 None None None 2020-07-13 17:35:20 UTC

Description Andrew Ballantyne 2020-05-05 14:31:33 UTC
Description of problem:
The secrets created in the Start Pipeline modal are clickable and they navigate to the secret resource details but do not close the modal.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. Add a pipeline
2. Open the Start Pipeline modal
3. Add a secret

Actual results:
Secret resource is clickable link

Expected results:
Secret resource is NOT clickable / not a link.

Additional info:

Comment 4 spathak@redhat.com 2020-05-14 23:54:21 UTC
Created attachment 1688673 [details]
Not Clickable Resource Link in the start pipeline modal

Comment 5 spathak@redhat.com 2020-05-14 23:54:51 UTC
Verified on build: 4.5.0-0.ci-2020-05-13-002458
Browser version: Firefox 69

Comment 6 errata-xmlrpc 2020-07-13 17:35:00 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:2409


Note You need to log in before you can comment on or make changes to this bug.