Bug 1831738 - ICE: attempting to access a gcc command line option that is not stored in global_options
Summary: ICE: attempting to access a gcc command line option that is not stored in glo...
Keywords:
Status: CLOSED DUPLICATE of bug 1817659
Alias: None
Product: Fedora
Classification: Fedora
Component: annobin
Version: 32
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Nick Clifton
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-05-05 14:36 UTC by jcpunk
Modified: 2020-05-05 15:32 UTC (History)
3 users (show)

Fixed In Version: annobin-9.21-1.fc32
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-05-05 15:32:32 UTC
Type: Bug


Attachments (Terms of Use)
koji build.log (11.24 KB, text/plain)
2020-05-05 14:36 UTC, jcpunk
no flags Details

Description jcpunk 2020-05-05 14:36:51 UTC
Created attachment 1685244 [details]
koji build.log

Description of problem:
Apparently I'm attempting something unexpected in my build of libx86 on Fedora 32.  This built as expected on Fedora 31.

Version-Release number of selected component (if applicable):
9.19-1.fc32

How reproducible:
100%

Steps to Reproduce:
1. Attempt to rebuild libx86 rpm for Fedora 32 (see additional info)
2.
3.

Actual results:
Build fails, see attached log

Expected results:
Build works on Fedora 32.

Additional info:
https://koji.fedoraproject.org/koji/taskinfo?taskID=44119590

Comment 1 Nick Clifton 2020-05-05 15:32:32 UTC
Hi jcpunk,

  I am sorry that you have run into this problem.  The good news is that it has already been fixed.
  You just need an updated version of annobin (9.21-1.fc32 to be exact).  I have filed a Bodhi
  request to have the update pushed, so it should be available soon.

Cheers
  Nick

*** This bug has been marked as a duplicate of bug 1817659 ***


Note You need to log in before you can comment on or make changes to this bug.