Bug 1831741 - Operator hub and catalog need proper input field labels
Summary: Operator hub and catalog need proper input field labels
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Management Console
Version: 4.5
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
: 4.5.0
Assignee: Jessie
QA Contact: Yadan Pei
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-05-05 14:42 UTC by Jessie
Modified: 2020-07-13 17:35 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-07-13 17:35:00 UTC
Target Upstream Version:


Attachments (Terms of Use)
Operator Hub input error (204.44 KB, image/png)
2020-05-05 14:42 UTC, Jessie
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Github openshift console pull 5302 0 None closed Bug 1831741: Operator hub and catalog need proper input field labels 2020-06-24 01:40:50 UTC
Red Hat Product Errata RHBA-2020:2409 0 None None None 2020-07-13 17:35:20 UTC

Description Jessie 2020-05-05 14:42:28 UTC
Created attachment 1685246 [details]
Operator Hub input error

Description of problem:
On the operator hub and catalog pages, the input field does not have an aria-label which can create issues for screen readers. While placeholder text provides valuable guidance for many users, placeholder text is not a replacement for labels. Assistive technologies, such as screen readers, do not treat placeholder text as labels. Placeholder text is also not broadly supported across assistive technologies. 

This issue gives the following axe error: 

{
    "data": null,
    "id": "aria-label",
    "impact": "serious",
    "message": "aria-label attribute does not exist or is empty",
    "relatedNodes": [
      {
        "html": "<input placeholder="Filter by keyword..." type="text" class="co-catalog-page__input pf-c-form-control" value="">"
      }
    ]
  }

Version-Release number of selected component (if applicable):


How reproducible:
You can see this error by using the Axe Chrome Extension.

Steps to Reproduce:
1. Go to http://localhost:9000/operatorhub or http://localhost:9000/catalog
2. Inspect the page and go to the axe tab.
3. Click "Analyze" - this issue is the one that says, "Form elements must have labels"

Actual results:
Input fields that are inaccessible for screen readers.

Expected results:
Input fields that are properly labeled for assistive technology.

Comment 4 Yanping Zhang 2020-05-11 11:39:17 UTC
Checked on ocp 4.5 cluster with payload 4.5.0-0.nightly-2020-05-10-231314.
Check filter input box on OperatorHub page and Catalog page, there is lable: aria-label="Filter by keyword...", and axe analyzing have not label error now.
The bug is fixed, so move it to Verified.

Comment 5 errata-xmlrpc 2020-07-13 17:35:00 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:2409


Note You need to log in before you can comment on or make changes to this bug.