Bug 183177 - sound-juicer can't find music data that is artist, album, and title.
sound-juicer can't find music data that is artist, album, and title.
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: sound-juicer (Show other bugs)
5
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: John (J5) Palmieri
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-02-27 00:16 EST by Takaki Hiroshi
Modified: 2013-03-13 00:49 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-03-10 18:06:45 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Desktop 330464 None None None Never

  None (edit)
Description Takaki Hiroshi 2006-02-27 00:16:31 EST
Description of problem:
sound-juicer can't find music data. Music data of my cdrom, Milk and Honey, is
in musicbrainz.

http://musicbrainz.org/album/97b1225d-c050-43a5-8d88-a55a5284141d.html


Version-Release number of selected component (if applicable):
sound-juicer-2.13.5-1

How reproducible:
Always.

Steps to Reproduce:
1. insert cd into drive
2. 
3.
  
Actual results:
Title: Unknown Title
Artist: Unknown Artist

Expected results:
Title: Milk and Honey
Artist: John Lennon & Yoko Ono

Additional info:
rhythmbox-0.9.3.1-1.2 in FC5 can find this. sound-juicer in FC3 can find this.

https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=138342
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=135538
Comment 1 John Thacker 2006-03-03 01:39:58 EST
Check to see if this still happens with sound-juicer-2.13.6.  The upstream
author turned off caching the metadata between 2.13.5, as it was breaking things.
Comment 2 Takaki Hiroshi 2006-03-03 08:27:46 EST
Thanks for your comment. But sound-juicer-2.13.6-1 in today's rawhide still not
works fine.
Comment 3 John Thacker 2006-03-07 22:43:35 EST
The album information is in MusicBrainz, but no DiscID exists for it in
MusicBrainz, so lookup won't work.  Try inserting your disc, selecting "Submit
Track Names" from the disc menu, and then looking up the Album in order to add
the DiscID.  You may need to create a MusicBrainz username to do so, I'm not sure.

This is expected behavior because there's a track listing but no DiscID in the
MusicBrainz database, and sound-juicer (and MusicBrainz) uses the DiscID to look
up CDs.  (Sometimes different replication batches of the same CD can have
different IDs, though, depending on how they were pressed.)  If you add the
DiscID, it should work.
Comment 4 John Thacker 2006-03-07 22:57:33 EST
From http://musicbrainz.org/cd_submission.html:

"However, there is a downside to this as well. Audio CD-ROMs are usually
produced in large batches, that may include thousands if not millions of copies
of one CD. Once a record company is done selling that one batch, or a record
company in another country wants to print up a batch of the same CD, they will
make another batch. There are over 10 different pressings for the album 'The
Dark Side of the Moon' by Pink Floyd, for instance.

If the CDs from the new batch are off by one sector (as mentioned above) they
will have a different unique Disc ID.

(中略)

Let's say you use one of the CD Submission tools to submit a CD and you find
that MusicBrainz doesn't know about the CD. You then proceed to select the
artist and then MusicBrainz shows you a list of CDs and your CD is right there
is in the list. What's wrong?

There may be a few things going on:

    * MusicBrainz may not have any Disc IDs for this album.
    * MusicBrainz may have a different Disc ID than you have, thus MusicBrainz
already knows about a different pressing of the CD. 

In either case, you should select the matching CD and let MusicBrainz create
another association for you. This means that MusicBrainz will now know about the
new Disc ID that you just reported. The next time you want to look up this CD,
MusicBrainz will gladly deliver the data to you."
Comment 5 Takaki Hiroshi 2006-03-10 18:06:45 EST
You are right. I got the expected results if I sent DiskID to MusicBrainz by
function of sound-juicer. Thanks!

Note You need to log in before you can comment on or make changes to this bug.