Bug 183186 - strace fails to build
strace fails to build
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: strace (Show other bugs)
4
All Linux
medium Severity medium
: ---
: ---
Assigned To: Roland McGrath
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-02-27 05:56 EST by JW
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version: 4.5.14-0.FC4.1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-04-25 03:07:26 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description JW 2006-02-27 05:56:01 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (compatible; MSIE 6.0; Windows; U; AIIEEEE!; Win98; Windows 98; en-US; Gecko masquerading as IE; should it matter?; rv:1.8b) Gecko/20050217

Description of problem:
strace fails to build because LINUX_QUOTA_VERSION has updated to 2.

Must be that nobody is doing regular full fedora builds!


Version-Release number of selected component (if applicable):
strace-4.5.11-1

How reproducible:
Always

Steps to Reproduce:
1.rpm -v -bc strace.spec
2.
3.
  

Actual Results:  resource.c:478: error: 'Q_SETUSE' undeclared here (not in a function)
resource.c:480: error: 'Q_SETQLIM' undeclared here (not in a function)
resource.c:481: error: 'Q_GETSTATS' undeclared here (not in a function)
resource.c:482: error: 'Q_RSQUASH' undeclared here (not in a function)


Expected Results:  No error output


Additional info:

The entries in resource.c need LINUX_QUOTA_VERSION #ifdefs to match those in /usr/include/sys/quota.h
Comment 1 Roland McGrath 2006-04-25 03:07:26 EDT
This is fixed in the current fc4 update.

Note You need to log in before you can comment on or make changes to this bug.