Bug 1831888 - Image triggers do not work on v1 StatefulSets
Summary: Image triggers do not work on v1 StatefulSets
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: openshift-controller-manager
Version: 4.3.0
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
: 4.3.z
Assignee: Adam Kaplan
QA Contact: wewang
URL:
Whiteboard:
: 1831246 (view as bug list)
Depends On: 1831245
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-05-05 20:19 UTC by OpenShift BugZilla Robot
Modified: 2020-07-07 14:48 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Cause: trigger controller was not aware of the GA version of StatefulSet Consequence: triggers could not work on v1.StatefulSet objects Fix: trigger controller now understands v1.StatefulSet Result: triggers work on v1.StatefulSet objects
Clone Of:
Environment:
Last Closed: 2020-07-07 14:48:25 UTC
Target Upstream Version:
adam.kaplan: needinfo-


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Github openshift openshift-controller-manager pull 116 None closed Bug 1831888: StatefulSets v1 do not trigger on image changes 2020-07-07 03:26:53 UTC
Red Hat Product Errata RHBA-2020:2805 None None None 2020-07-07 14:48:42 UTC

Description OpenShift BugZilla Robot 2020-05-05 20:19:32 UTC
This is a clone of Bug #1831243. This is the description of that bug:
When trying to trigger based on a v1 StatefulSet, this message is printed to the logs and no trigger occurs:

I0504 18:07:01.962652       1 image_trigger_controller.go:332] Error syncing resource statefulsets.apps/clayton-ci-search/search: unrecognized object - no trigger update possible for *v1.StatefulSet

Will be backported.

Comment 3 Adam Kaplan 2020-05-26 15:16:56 UTC
*** Bug 1831246 has been marked as a duplicate of this bug. ***

Comment 9 wewang 2020-06-28 01:53:55 UTC
Verified in version,steps are the same with bz1831243
Version:
4.3.0-0.nightly-2020-06-27-134851

Comment 11 errata-xmlrpc 2020-07-07 14:48:25 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:2805


Note You need to log in before you can comment on or make changes to this bug.