Bug 183206 - Installer exits abnormally 5 secs after running anaconda, text & graphics mode
Installer exits abnormally 5 secs after running anaconda, text & graphics mode
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
5
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-02-27 09:00 EST by peter gal
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-27 20:03:17 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description peter gal 2006-02-27 09:00:28 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.8) Gecko/20050524 Fedora/1.0.4-4 Firefox/1.0.4

Description of problem:
Mboard is Intel D925XBC
CPU is Intel 3.66 GHz
Graphics is ATI Radeon X300SE PCI-X
Harddisk x 1 is SATA-1
Installer DVD (USB2 enclosure) attached to USB port on mboard
(Local NFS server also used)


Install setup/options: 

Installer DVD (USB2 enclosure) attached to USB port on mboard
Boot from DVD
<enter> (graphical mode), 
Keyb=US 
Lang=US 
Source=DVD 
Perform CRC check = yes, (passes each time)


Symptoms: 

1) After booting from FC5-test3 installer DVD inserted into external DVD-ROM drive, and after providing above options, TTY1 displays "Running anaconda.....", then after 5 seconds displays "Install exiting abnormally" and shuts down.

2) If I intercept "Running anaconda..." with Ctrl-s and switch to TTY3, I see the following:
   ...blah...
   ...blah...
   ...blah...
   21:26:46 INFO   : USB mouse found, loading mousedev module
   21:26:46 INFO   : modules to insert mousedev
   21:26:46 INFO   : load module set done
   21:26:46 ERROR  : failed to loading mousedev module
   21:26:46 INFO   : Running anaconda script /usr/bin/anaconda

<that's it>

3) If I then switch to TTY4 I see the following:
   ...blah...
   ...blah...
   ...blah...
   <6>SGI XFS with ACLs, security attributes, large block numbers, no debug enable
   <6>SGI XFS Quota Management subsystem
   <6>device-mapper: 4-5-0-ioctl (2005-10-04) initialised: dm-devel@redhat.com

<that's it>

4) If I switch to TTY2 and type "ddcprobe" I get a successful graphics card and monitor detection, ie:

   Videocard autoprobe results
   Description:  ATI Technologies Inc. V300
   Memory (MB):  16

   Monitor autoprobe results
   ID: BNQ7652
   Name: BenQ FP547
   Horizontal Sync (kHZ): 31-63
   Vertical Sync (HZ): 56-75
   Width (mm): 300
   Height (mm): 230

5) If I retry with "linux nokill", I don't get any more messages.

6) If I retry with "linux text", I don't get any more messages.

7) If I retry and install over-the-wire from my NFS server, and specify an IP address and NFS server, the installer mounts the NFS folder, but then fails at the same place, and I don't get any more messages.

8) Here's an interesting difference I observe between the FC5-test2 (which works) and FC5-test3 install sequences:

   a) FC5-test2  autoloads the disk drivers in the following sequence:
        i)   usb-storage driver
        ii)  ohci1394 driver
        iii) ahci driver

   b) FC5-test3  autoloads the disk drivers in the following sequence:
        i)   usb-storage driver
        ii)  ohci1394 driver
        iii) ata_piix driver
        iv)  usb-storage driver   <--- Hmmmm loads a second time!



Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:

1. Insert DVD in external DVD-ROM drive case connect to mboard USB2 port via USB2 cable.

2. Boot from DVD

3. Hit <enter> to boot graphical  (no difference if "linux text")

4. Provide following answers when requested:
   Keyb=US 
   Lang=US 
   Source=CD (DVD) 
   Perform CRC check = yes, (passes each time)

5. Observe anaconda error and auto shutdown.





Actual Results:  After specifying "test CD or "skip CD", get message: "Running anaconda....", and 5 seconds later "install exited abnormally:.


Expected Results:  Instead of "install exited abnormally", anaconda should display messages relating to probing graphics, monitor, mouse, then start X server.

Additional info:
Comment 1 Jeremy Katz 2006-02-27 13:09:06 EST
I take it you have no internal DVD drive so you can test with the USB DVD drive
disconnected?
Comment 2 peter gal 2006-02-27 19:53:27 EST
I attached a DVD-ROM to the mboard's internal IDE port via an extremely
electrically dangerous setup and installed FC5-test3 from that drive successfully.

That narrows it down a lot, well done.

However we'd really appreciate a way to install from an externally attached
USB-DVD-ROM drive ?

Ie: Unfortunately for us the 12 boxes of this type which we own don't have room
for any internally mounted DVD-ROM drives, even slimline, because they're ultra
compact "no legacy" boxes.  (All internal drives SATA. USB mouse/keyboard)

I tried reconnecting the external DVD-ROM to the mboard via firewire instead of
USB, but BIOS didn't discover it. 
Comment 3 Jeremy Katz 2006-02-27 20:03:17 EST
Okay, that narrows it down to the USB drive.  The changes I made in CVS today
should hopefully fix this.

Note You need to log in before you can comment on or make changes to this bug.