Bug 18322 - Amanda client problems
Amanda client problems
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: amanda (Show other bugs)
7.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Trond Eivind Glomsrxd
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-10-04 08:29 EDT by Jim Simmons
Modified: 2007-04-18 12:28 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-01-04 18:34:27 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jim Simmons 2000-10-04 08:29:05 EDT
After installing the amanda client, amcheck from the server fails because
the operator account home directory in RedHat 7.0 is /root, which is owned
by root
instead of operator.  Changing the operator home directory to another
directory (/home/operator), making amanda
the owner, making sure it is not group or world writable, then moving
.amandahosts to it fixes this problem.  It
might be better to use a separate amanda account (make sure it is in group
disk, of course).

Also, the /etc/xinetd.d/amanda file isn't created if you just install
amanda and amanda-client (this has already been
reported through bugzilla, however).

amanda-client also does not create /var/lib/amanda/gnutar-lists and make
amanda the owner (which is used if
you use gnu tar for backups instead of dump).

Finally, with gnu-tar you get warnings when amanda is run like:
	? gtar: ./tmp/.X11-unix/X0: socket ignored 
This is a known amanda problem and can be fixed by patching
client-src/sendbackup-gnutar.c and adding:
	 { DMP_NORMAL, ": socket ignored", 1},
right before the line:
              #ifdef IGNORE_SMBCLIENT_ERRORS
Comment 1 Jeff Johnson 2000-10-12 15:19:19 EDT
All but changing the operator home directory are fixed in
amanda-2.4.2-0.19991216beta1.1.
Comment 2 Seth Vidal 2001-01-04 18:34:24 EST
the amanda operator home dir is another slight problem if you already have an
.amandahosts file - b/c it runs as a script to update that file you run the risk
of munging the hell out of it.

make it an actual file so in the event it installs it can be saved as a .rpmsave
or a .rpmnew

otherwise you end up with a kludged file - and on the client as well.
your best bet is to leave .amandahosts alone and not add anything to it.
Comment 3 Trond Eivind Glomsrxd 2001-01-30 20:10:11 EST
All of this should be fixed in amanda 2.4.2-2, coming soon to a rawhide near you.
Comment 4 Rupa Schomaker 2001-02-07 18:55:54 EST
I've "fixed" this by:

1) ensuring operator is in the "root" group (it should be)

2) making sure /root is g+rx

3) adding the line "groups = yes" for /etc/xinetd.d/amanda (and other amanda 
services).

This tells xinetd to give the service all supplemental groups for the user 
specified.  Now, since /root is g+rx, the service can read the .amandahosts 
file.  

Having an "amanda" user is probably optimal, but the above is a nice quick 
workaround.
Comment 5 Trond Eivind Glomsrxd 2001-02-07 19:02:31 EST
A amanda user was added in the RPMs I referred to

Note You need to log in before you can comment on or make changes to this bug.