Bug 1832220 - Make insights operator grab events from openshift-etcd-operator in case OAS is degraded
Summary: Make insights operator grab events from openshift-etcd-operator in case OAS i...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: openshift-apiserver
Version: 4.5
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: 4.5.0
Assignee: Stefan Schimanski
QA Contact: Xingxing Xia
URL:
Whiteboard:
Depends On:
Blocks: 1832226
TreeView+ depends on / blocked
 
Reported: 2020-05-06 10:54 UTC by Michal Fojtik
Modified: 2020-07-13 17:35 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1832226 (view as bug list)
Environment:
Last Closed: 2020-07-13 17:35:22 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift cluster-openshift-apiserver-operator pull 360 0 None open Bug 1832220: operator: add openshift-etcd-operator namespace to related objects 2020-06-24 01:45:24 UTC
Red Hat Product Errata RHBA-2020:2409 0 None None None 2020-07-13 17:35:43 UTC

Description Michal Fojtik 2020-05-06 10:54:44 UTC
Description of problem:

In some cases, when OAS is degraded it is due to etcd leader elections or connection issues to etcd itself.

We need to be able to see events from etcd operator, to detect these and be able to root cause the OAS behavior better,


Version-Release number of selected component (if applicable):


How reproducible:

This is not a bug, but improving debugging/stability. No QE needed.

Comment 3 Xingxing Xia 2020-05-06 14:39:21 UTC
Thanks

Comment 4 errata-xmlrpc 2020-07-13 17:35:22 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:2409


Note You need to log in before you can comment on or make changes to this bug.