Bug 1832280 - Visual connector cannot distinguish between nodes of different kinds
Summary: Visual connector cannot distinguish between nodes of different kinds
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Dev Console
Version: 4.5
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: 4.5.0
Assignee: divgupta
QA Contact: Gajanan More
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-05-06 13:01 UTC by divgupta
Modified: 2020-07-13 17:35 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-07-13 17:35:22 UTC
Target Upstream Version:


Attachments (Terms of Use)
Visual connector can distinguish between nodes of different kinds (52.78 KB, image/png)
2020-05-22 13:22 UTC, spathak@redhat.com
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Github openshift console pull 5313 0 None open Bug 1832280: Fix visual connector to distinguish between nodes of different kinds 2020-06-24 01:46:04 UTC
Red Hat Product Errata RHBA-2020:2409 0 None None None 2020-07-13 17:35:43 UTC

Description divgupta 2020-05-06 13:01:43 UTC
Description of problem:
The visual connector creates a `connects-to` annotation whose value is a comma separated or JSON array list of `app.kubernetes.io/instance` strings for matching to their target. The problem is that the `instance` is just a name and is not unique amongst resources.

The value of the annotation needs to be able to uniquely identify different resources by kind and name.

How reproducible: Always

Steps to Reproduce:
1. Create different kinds of resources(that are shown in topology) with same name in a project.
2. Try to connect a node with a node whose name is same as some other nodes.
3. Connection is made to other node with the same name as target node.

Actual results:
Connection is made to other node with the same name as target node.

Expected results:
Connection should be made to the target node.

Comment 5 spathak@redhat.com 2020-05-22 13:22:18 UTC
Created attachment 1691059 [details]
Visual connector can distinguish between nodes of different kinds

Comment 6 spathak@redhat.com 2020-05-22 13:55:33 UTC
https://issues.redhat.com/browse/ODC-2478?focusedCommentId=14110914&page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel#comment-14110914

Verified on build version: 4.5.0-0.ci-2020-05-22-080435
Browser version: Firefox 73

Comment 7 errata-xmlrpc 2020-07-13 17:35:22 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:2409


Note You need to log in before you can comment on or make changes to this bug.