Bug 1832294 - Provide telemetry metrics for DeploymentConfig and especially strategies used
Summary: Provide telemetry metrics for DeploymentConfig and especially strategies used
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: openshift-controller-manager
Version: 4.5
Hardware: Unspecified
OS: Unspecified
high
urgent
Target Milestone: ---
: 4.5.0
Assignee: Tomáš Nožička
QA Contact: zhou ying
URL:
Whiteboard: workloads
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-05-06 13:38 UTC by Maciej Szulik
Modified: 2020-07-13 17:35 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-07-13 17:35:31 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift openshift-controller-manager pull 111 0 None closed Bug 1832294: Add strategy metrics 2020-06-24 01:46:05 UTC
Red Hat Product Errata RHBA-2020:2409 0 None None None 2020-07-13 17:35:48 UTC

Description Maciej Szulik 2020-05-06 13:38:51 UTC
We need number for how many DeploymentConfigs is being using in the wild and which strategies are being used. This is needed partially to help with https://issues.redhat.com/browse/WRKLDS-118

Comment 4 zhou ying 2020-06-01 03:52:52 UTC
Confirmed with payload: 4.5.0-0.nightly-2020-05-30-025738, could query by 'openshift_apps_deploymentconfigs_strategy_total' now.

Comment 5 errata-xmlrpc 2020-07-13 17:35:31 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:2409


Note You need to log in before you can comment on or make changes to this bug.