Bug 183234 - usb-storage does not support Sony DSC-S600 camera
usb-storage does not support Sony DSC-S600 camera
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
4
All Linux
medium Severity medium
: ---
: ---
Assigned To: Pete Zaitcev
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-02-27 12:30 EST by Patrick Monnerat
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version: 2.6.17-1.2139_FC4
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-06-29 11:01:46 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch to enable usb-storage on Sony DSC-S600 (812 bytes, patch)
2006-02-27 12:30 EST, Patrick Monnerat
no flags Details | Diff
Upstream patch (686 bytes, patch)
2006-02-27 13:43 EST, Pete Zaitcev
no flags Details | Diff

  None (edit)
Description Patrick Monnerat 2006-02-27 12:30:33 EST
Description of problem: As the DSC-T1, The Sony DSC-S600 camera reports a 
subclass of 0xff on the storage interface. It is then not possible to mount it.


Version-Release number of selected component (if applicable):
kernel-2.6.15-1.1831_FC4

How reproducible: Always


Steps to Reproduce:
1. Turn the DSC-S600 to usb mass-storage mode
2. Plug the DSC-S600 to the computer
3.
  
Actual results:
Nothing happens. /proc/bus/usb/devices shows "driver=(none)" for the interface.


Expected results: Automatic mount of device. /proc/bus/usb/device should 
show "Driver=usb-storage".


Additional info:
Vendor=054c ProdID=0010 Rev= 6.00
Cls=08(stor.) Sub=ff Prot=01

Please find new entry for that device in the attached patch file.
Comment 1 Patrick Monnerat 2006-02-27 12:30:33 EST
Created attachment 125332 [details]
Patch to enable usb-storage on Sony DSC-S600
Comment 2 Pete Zaitcev 2006-02-27 13:43:44 EST
Created attachment 125335 [details]
Upstream patch

No need to create a whole new entry just because Sony revved the firmware
from 5.00 to 6.00.
Comment 3 Pete Zaitcev 2006-02-27 13:46:26 EST
Since we're almost at FC-5, I'm reluctant to ask DaveJ to integrate this.
Can you get by with FC-5 kernels for a few months? They are binary
compatible. Just slap them on top of the distro (rpm -i) without removing
the normal FC_4 kernel and you'll be fine.
Comment 4 Patrick Monnerat 2006-02-28 04:08:50 EST
'didn't dare doing that, because I dont know about rev 5.01 to 5.99, but 
evidently it should work.
Is the FC5 kernel already ready for DSC-S600 ?
Comment 5 Patrick Monnerat 2006-06-29 11:01:46 EDT
Fixed in kernel-2.6.17-1.2139_FC4.

Note You need to log in before you can comment on or make changes to this bug.