Bug 1832344 - After upgrade, openshift-samples is moving between ready and "Progressing" status
Summary: After upgrade, openshift-samples is moving between ready and "Progressing" st...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Samples
Version: 4.4
Hardware: Unspecified
OS: Unspecified
medium
high
Target Milestone: ---
: 4.4.z
Assignee: Gabe Montero
QA Contact: XiuJuan Wang
URL:
Whiteboard:
: 1832193 1842901 (view as bug list)
Depends On: 1828065
Blocks: 1841996
TreeView+ depends on / blocked
 
Reported: 2020-05-06 14:54 UTC by Gabe Montero
Modified: 2020-06-02 12:08 UTC (History)
12 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Cause: if a sample template available in a prior release was removed in a subsequent release, then during upgrade to that subsequent release the removed template could be incorrectly tracked as needing to be updated, and the subsequent failure to read that template from the current payload leads to confusing 'no such file or directory error reading file []' messsages and apiserver errors reported in the samples clusteroperator status Consequence: overall upgraded could be marked as failed if the problematic timing windows in samples operator occurred Fix: samples operated was updated to not attempt to update templates which existed in a prior release but not in the release we are upgrading to Result: templates that are removed release to release should not cause samples operator to fail upgrade or report confusing clusteroperator status
Clone Of: 1828065
Environment:
Last Closed: 2020-06-02 11:18:33 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Github openshift cluster-samples-operator pull 269 None closed Bug 1832344: correctly handle removed templates watch events as part of an upgrade 2020-08-03 02:19:57 UTC
Red Hat Product Errata RHBA-2020:2310 None None None 2020-06-02 11:19:09 UTC

Comment 1 Vadim Rutkovsky 2020-05-06 15:59:03 UTC
*** Bug 1832193 has been marked as a duplicate of this bug. ***

Comment 2 Scott Dodson 2020-05-20 19:03:53 UTC
Bumping to high because anything that improves signal to noise ratio after upgrades is worthy of high.

Comment 6 XiuJuan Wang 2020-05-25 10:27:40 UTC
Can't reproduce this issue when upgrade from 4.3.0-0.nightly-2020-05-24-223407 to 4.4.0-0.nightly-2020-05-25-020741

Comment 8 errata-xmlrpc 2020-06-02 11:18:33 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:2310

Comment 9 Gabe Montero 2020-06-02 12:08:50 UTC
*** Bug 1842901 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.