Bug 183245 - NM fails to notice successful authentication
NM fails to notice successful authentication
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: NetworkManager (Show other bugs)
5
powerpc Linux
medium Severity high
: ---
: ---
Assigned To: Dan Williams
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-02-27 14:25 EST by Dennis Gilmore
Modified: 2008-01-22 09:39 EST (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-22 09:39:36 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
partial output in /var/log/messages (4.44 KB, text/plain)
2006-02-27 14:25 EST, Dennis Gilmore
no flags Details
strace of nm trying to connect to network (194.41 KB, text/plain)
2006-03-02 13:48 EST, Dennis Gilmore
no flags Details
strace of wpa_supplicant succesfully connecting to the network (24.43 KB, text/plain)
2006-03-02 13:50 EST, Dennis Gilmore
no flags Details
NetworkManager output while failing to connect. (49.78 KB, text/plain)
2006-03-27 10:11 EST, David Woodhouse
no flags Details
Log of WEP failing too (8.17 KB, text/plain)
2006-03-27 10:26 EST, David Woodhouse
no flags Details
send assoc/disassoc events to userspace (2.85 KB, patch)
2006-03-27 21:44 EST, Dan Williams
no flags Details | Diff
NetworkManager output with WPA and patched softmac (66.20 KB, text/plain)
2006-03-28 02:26 EST, David Woodhouse
no flags Details

  None (edit)
Description Dennis Gilmore 2006-02-27 14:25:12 EST
Description of problem:  
  
When using Network manage on a Powerbook nm sees the networks  and nm-tools  
lists it can do wpa for the card  it is a in built broadcom  bcm43xx based 
card.   when i try to associate with the wireless network i am unable to   i 
enter the WPA psk and can never click on the button to connect.  in the 
console i see  
** (nm-applet:4558): CRITICAL **: cipher_wpa_psk_passphrase_hash_func: 
assertion `ssid_len > 0' failed 
 
if i manually enter the information in to connect to the network it attempts 
to connect  but i get a stream of messages in /var/log/messages   attached is 
partial output 
  
Version-Release number of selected component (if applicable):  
 NetworkManager-0.5.1-14.cvs20060221 
  
How reproducible:  
 always 
  
Steps to Reproduce:  
1. start nm and nm-applet  
2. try to connect to network 
3.  
    
Actual results:  
 connection does not happen 
  
Expected results:  
 connection achieved 
  
Additional info:  
 
if i use wpa_supplicant i am able to connect to the network.  so wpa works on 
this card.  just not inside nm
Comment 1 Dennis Gilmore 2006-02-27 14:25:12 EST
Created attachment 125339 [details]
partial output in /var/log/messages
Comment 2 David Woodhouse 2006-03-02 12:08:57 EST
Almost certainly the fault is with bcm43xx not NM. The bcm43xx driver is very
picky about the order in which the initialisation steps are performed.

Dennis, am I right in thinking that this works fine if you do it all manually
rather than using NM? Can you try to work out what the difference is?
Comment 3 Dennis Gilmore 2006-03-02 13:48:47 EST
Created attachment 125553 [details]
strace of nm  trying to connect to network
Comment 4 Dennis Gilmore 2006-03-02 13:50:38 EST
Created attachment 125554 [details]
strace of wpa_supplicant succesfully  connecting to the network
Comment 5 John W. Linville 2006-03-03 10:12:04 EST
Just updated rawhide's bcm43xx code, also available in test kernels here: 
 
   http://people.redhat.com/linville/kernels/fc5/ 
 
I don't know if it will help this or not, but it included several bcm43xx 
changes...? 
Comment 6 Dennis Gilmore 2006-03-03 11:53:18 EST
i assume that the rawhide changes will be in toomoorow march 4?  I will try 
rebuilding the srpm  and test it today. 
Comment 7 Dennis Gilmore 2006-03-03 17:37:48 EST
OK no different.  
  
Im not sure of the best way to debug this  but here is some things im seeing  
  
NM  shows the networks.  but due to   
** (nm-applet:4558): CRITICAL **: cipher_wpa_psk_passphrase_hash_func:  
assertion `ssid_len > 0' failed 
i can't enter my passphrase in nm so while nm knows the ssid  somewhere its 
messing it up.   
 
i guess there is two issues  that is one   the other 
 
if i create the network manually in nm   i can enter the passprase  as it 
knows the ssid length is bigger  than 0 .half the time after the attempt to 
connect fails they keyboard no longer works  sometimes the machine locks up 
the rest of the time  nothing adverse happens  the machine just doesnt connect 
to the network. 
 
wpa_supplicant when configured works  i can start wpa_supplicant and then run 
dhclient  and i get an ip and its ok.   
 
David there were some slight differences in the way NM connected to what 
wpa_supplicant but i don't know the code well enough to say exactly  what was 
different. 
Comment 8 David Woodhouse 2006-03-25 12:03:09 EST
OK, if it's still happening in the latest kernels then I'm no longer going to
assert that it's "almost certainly bcm43xx's fault", although that's certainly
still a possibility. NM folks, any ideas? 

I've finally got round to testing WPA for myself and it works for me with
wpa_supplicant, at least when the SSID is broadcast by the AP. I haven't yet
upgraded my laptop to FC5 though because of other problems -- is it possible to
run the new NM on FC4? (I'm happy to upgrade almost everything to FC5 as long as
I can keep the working Evolution from FC4)
Comment 9 David Woodhouse 2006-03-27 10:11:29 EST
Created attachment 126821 [details]
NetworkManager output while failing to connect.

I see the same behaviour. If I change my AP to use WPA, first it just fails to
conenct -- I think it's confused because the same AP _used_ to have a WEP key. 


NetworkManager: <information>	wpa_supplicant(2666): 0: 00:06:25:4b:55:f8
ssid='Baythorne Wavelan' wpa_ie_len=26 rsn_ie_len=0 caps=0x11
NetworkManager: <information>	wpa_supplicant(2666):	 skip WPA IE - key mgmt
mismatch
NetworkManager: <information>	wpa_supplicant(2666): No suitable AP found.


So I changed the SSID on the AP too, and then I was asked for a password -- but
still the 'Login to network' button remained greyed out, as reported above.

I used the suggested workaround, of creating the network manually. This still
failed -- the output from NetworkManager is attached.

This works with wpa_supplicant from the command line.
Comment 10 David Woodhouse 2006-03-27 10:26:42 EST
Created attachment 126826 [details]
Log of WEP failing too

It seems to fail with WEP too -- at least it _thinks_ it did. Actually, it
manages to associate and I can see traffic on the network and I have an IPv6
address. But it never sends DHCP requests and it takes the network down 20
seconds later.
Comment 11 David Woodhouse 2006-03-27 20:37:58 EST
I see this with prism54 too -- it authenticates, but never manages to work out
that it succeeded. This was working with the FC4 NetworkManager, on the same kernel.
Comment 12 Dan Williams 2006-03-27 21:43:14 EST
Right, so is softmac actually sending wireless events to userspace saying that
it's authenticated?  I posted a patch to netdev@ a while ago that added
disconnect notification support to softmac, but it turned out that nothing in
softmac ever called the auth/death notification routines.

Patch to softmac attached.  Could you take a look and see about the auth/death
stuff in softmac, Dave?
Comment 13 Dan Williams 2006-03-27 21:44:42 EST
Created attachment 126870 [details]
send assoc/disassoc events to userspace
Comment 14 David Woodhouse 2006-03-28 02:20:12 EST
iwevent output during 'ifup eth1' before your patch:

08:01:01.776055   eth1     Set Mode:Auto
08:01:01.798186   eth1     Set Encryption key:****-****-**
08:01:01.824763   eth1     Set ESSID:"Baythorne Wavelan"
08:01:02.285027   eth1     Custom driver event:authenticated
08:01:02.286298   eth1     Custom driver event:associated

.... and after it:

08:07:17.469059   eth1     Set Mode:Auto
08:07:17.491375   eth1     Set Encryption key:****-****-**
08:07:17.516047   eth1     Set ESSID:"Baythorne Wavelan"
08:07:18.261663   eth1     Custom driver event:scan finished
08:07:18.279435   eth1     Custom driver event:authenticated
08:07:18.283052   eth1     New Access Point/Cell address:00:06:25:4B:55:F8

NetworkManager now works with WEP on the bcm43xx -- although this won't help
prism54 which was _also_ working in FC4.

The bcm43xx still doesn't work with WPA though -- even if I change the ESSID and
use the 'Connect to Other Wireless Network' option to work around the problems
above, I get this... 

08:20:02.989708   eth1     Set ESSID:""
08:20:03.277364   eth1     Custom driver event:scan finished
08:20:04.978297   eth1     Set Encryption key:off
08:20:04.983310   eth1     Set Mode:Managed
08:20:06.036417   eth1     Set Mode:Managed
08:20:06.644942   eth1     Custom driver event:scan finished
08:20:09.328103   eth1     Set Mode:Managed
08:20:09.346191   eth1     Set ESSID:"Baythorne Wavelan2"
08:20:09.346320   eth1     Set Mode:Managed
08:20:09.346411   eth1     Set ESSID:"Baythorne Wavelan2"
08:20:09.346502   eth1     Custom driver event:authenticated
08:20:09.350766   eth1     New Access Point/Cell address:00:06:25:4B:55:F8
08:20:09.674594   eth1     Custom driver event:scan finished
08:20:09.674661   eth1     New Access Point/Cell address:Not-Associated
08:20:09.686865   eth1     New Access Point/Cell address:00:06:25:4B:55:F8
08:20:10.124914   eth1     Custom driver event:scan finished
08:20:13.696684   eth1     New Access Point/Cell address:Not-Associated
08:20:13.707291   eth1     Custom driver event:authenticated
08:20:13.707441   eth1     New Access Point/Cell address:00:06:25:4B:55:F8
08:20:14.152921   eth1     Custom driver event:scan finished
08:20:17.733497   eth1     New Access Point/Cell address:Not-Associated
08:20:17.740860   eth1     Custom driver event:authenticated
08:20:17.741021   eth1     New Access Point/Cell address:00:06:25:4B:55:F8
08:20:18.176918   eth1     Custom driver event:scan finished
08:20:21.780912   eth1     New Access Point/Cell address:Not-Associated
08:20:21.784223   eth1     Custom driver event:authenticated
08:20:21.784355   eth1     New Access Point/Cell address:00:06:25:4B:55:F8
08:20:22.208941   eth1     Custom driver event:scan finished
08:20:25.865748   eth1     New Access Point/Cell address:Not-Associated
08:20:25.872821   eth1     Custom driver event:authenticated
08:20:25.872946   eth1     New Access Point/Cell address:00:06:25:4B:55:F8
08:20:26.228804   eth1     Custom driver event:scan finished
08:20:29.148874   eth1     Set Mode:Managed
08:20:29.313218   eth1     Set ESSID:""
08:20:29.313269   eth1     New Access Point/Cell address:Not-Associated
08:20:29.313283   eth1     New Access Point/Cell address:00:06:25:4B:55:F8
08:20:29.313300   eth1     Custom driver event:scan finished
08:20:31.259778   eth1     Set Encryption key:off
08:20:31.268979   eth1     Set Mode:Managed


Comment 15 David Woodhouse 2006-03-28 02:26:07 EST
Created attachment 126885 [details]
NetworkManager output with WPA and patched softmac

This is the output of NetworkManager corresponding to the iwevent output in
comment #14.
Comment 16 David Woodhouse 2006-04-05 21:28:38 EDT
The patch in comment #13 is in the 2.6.16-1.2084_FC5 kernel available from
http://people.redhat.com/davej/kernels/Fedora/FC5/

As stated in comment #14, it fixes WEP support in NetworkManager but not WPA.
WPA works if you use wpa_supplicant manually.
Comment 17 Patrick 2006-06-29 03:45:38 EDT
Just a me too comment regarding dwmw2's #16. I can successfully authenticate to
a SpeedTouch 716 using bcm43xx, 2139 kernel and WPA-PSK CCMP/AES if I use
wpa_supplicant manually on FC5 and issue ifup eth1. If I use NetworkManager both
WPA-PSK TKIP and WPA-PSK CCMP/AES don't work. Cable connections are fine though.
Comment 18 Dennis Gilmore 2008-01-22 09:39:36 EST
im going to close this as i no longer have the hardware to test and fedora 5 is
long since been unsupported.

Note You need to log in before you can comment on or make changes to this bug.