Bug 183249 - Refactor version handling
Refactor version handling
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: eclipse-bugzilla (Show other bugs)
rawhide
All Linux
medium Severity high
: ---
: ---
Assigned To: Jonathan Blandford
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-02-27 14:52 EST by Igor Foox
Modified: 2013-04-02 00:20 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-09-11 10:25:05 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Igor Foox 2006-02-27 14:52:26 EST
Description of problem:
The current code base has a pretty backwards way of dealing with different
versions of Bugzilla. Basically it boils down to the fact that you need a
separate class hirarchy (thankfully consisting of only 2 or 3 classes) for each
new version. The problem is that there is pretty much no change between some
versions, and then only thing that needs to be changed is checking that the
correct version is used. This needs to be cleared up by either changing the way
the version is detected and the way the BugzillaFactory works, or by making a
class that is not version specific but is something like 18+ or 18_and_up.

Version-Release number of selected component (if applicable):
0.2.2
Comment 1 Red Hat Bugzilla 2007-09-11 00:05:32 EDT
User klee@redhat.com's account has been closed
Comment 2 Andrew Overholt 2007-09-11 10:25:05 EDT
We are now shipping Mylyn which obsoletes the old bugzilla plugin.  Please open
a request at bugs.eclipse.org against Mylyn if this issue persists.  Thank you.

Note You need to log in before you can comment on or make changes to this bug.