Bug 1832509 - Topology access error if any resource is restricted from the user
Summary: Topology access error if any resource is restricted from the user
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Dev Console
Version: 4.5
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: 4.5.0
Assignee: Jeff Phillips
QA Contact: Gajanan More
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-05-06 18:19 UTC by Jeff Phillips
Modified: 2020-07-13 17:35 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
Clone Of:
Environment:
Version: 4.5.0-0.ci-2020-05-06-103028 Cluster ID: 8650c004-089c-4abe-8740-a107b762c7cf Browser: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_14_6) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/81.0.4044.138 Safari/537.36
Last Closed: 2020-07-13 17:35:31 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift console pull 5318 0 None closed Bug 1832509: Fix to show available items in topology when some are restricted 2020-06-24 01:46:13 UTC
Red Hat Product Errata RHBA-2020:2409 0 None None None 2020-07-13 17:35:48 UTC

Description Jeff Phillips 2020-05-06 18:19:07 UTC
Description of problem:

Viewing the topology is restricted if any of the resources are restricted. The user should be allowed to see the resource they have permission to veiw.

Version-Release number of selected component (if applicable):


How reproducible:

Always

Steps to Reproduce:
1. Create a project with several resources, DC, D, SS, and DS.
2. Create a user with access to only DCs.
3. Login as that user and navigate to Developer -> Topology

Actual results:

User gets a Restricted Access page

Expected results:

User sees topology view but only the deployment config resources

Additional info:

Comment 3 Gajanan More 2020-06-02 08:37:26 UTC
I have validated the bugzilla on:
Build: 4.5.0-0.nightly-2020-06-01-165039
Browser: Google Chrome Version 81.0.4044.129
Marking this as verified.

Comment 4 errata-xmlrpc 2020-07-13 17:35:31 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:2409


Note You need to log in before you can comment on or make changes to this bug.