Bug 1832561 - Health Checks alert should not visible to the user has view access
Summary: Health Checks alert should not visible to the user has view access
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Dev Console
Version: 4.5
Hardware: Unspecified
OS: Unspecified
high
medium
Target Milestone: ---
: 4.5.0
Assignee: Vikram Raj
QA Contact: Gajanan More
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-05-06 20:23 UTC by Vikram Raj
Modified: 2020-07-13 17:35 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-07-13 17:35:31 UTC
Target Upstream Version:


Attachments (Terms of Use)
Health Checks alert are not visible to the user has view access (233.10 KB, image/png)
2020-05-09 06:57 UTC, Gajanan More
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Github openshift console pull 5323 0 None open Bug 1832561: Health Checks alert should not visible to the user has view access 2020-06-24 01:46:14 UTC
Red Hat Product Errata RHBA-2020:2409 0 None None None 2020-07-13 17:35:48 UTC

Description Vikram Raj 2020-05-06 20:23:13 UTC
Description of problem:
Health Checks alert should not be visible on the topology overview page to the user has view access to the namespace.


How reproducible:


Steps to Reproduce:
1. Login as a developer.
2. Switch to namespace for which the developer have view access.
3. Navigate to topology view and click on the node which has no health checks added.
4. On the overview panel, you will see the Health checks alert. 

Actual results:
Health Checks alert is visible to the user has view access

Expected results:
Health Checks alert should not visible to the user has view access

Comment 3 Gajanan More 2020-05-09 06:57:49 UTC
Created attachment 1686695 [details]
Health Checks alert are not visible to the user has view access

Comment 4 Gajanan More 2020-05-09 07:00:34 UTC
I have validated the bugzilla on the
Build: 4.5.0-0.ci-2020-05-09-014245
Browser: Google Chrome Version 81.0.4044.129
Please have a look at the shared screenshot
Marking this as verfied

Comment 5 errata-xmlrpc 2020-07-13 17:35:31 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:2409


Note You need to log in before you can comment on or make changes to this bug.