Bug 183258 - libfac: build failure (gcc-4.1?)
libfac: build failure (gcc-4.1?)
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: libfac (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Rex Dieter
Fedora Extras Quality Assurance
:
Depends On:
Blocks: 183265
  Show dependency treegraph
 
Reported: 2006-02-27 15:12 EST by Rex Dieter
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-03-30 11:51:52 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch against factory 2.0.5 (1.34 KB, patch)
2006-03-28 05:21 EST, Michael Schwendt
no flags Details | Diff

  None (edit)
Description Rex Dieter 2006-02-27 15:12:44 EST
build fails on fc5/gcc-4.1,
http://buildsys.fedoraproject.org/logs/fedora-development-extras/3992-libfac-2.0.5-3.fc5.1/

c++ -O2 -g -pipe -Wall -Wp,-D_FORTIFY_SOURCE=2 -fexceptions -fstack-protector
--param=ssp-buffer-size=4 -m32 -march=i386 -mtune=generic
-fasynchronous-unwind-tables -fno-implicit-templates -I./factor -I./charset -I.
-I./factor -I/usr/include   -DNOSTREAMIO=1   -c factor/Factor.cc -o OPTOBJ/Factor.o
factor/Factor.cc: In function 'CFFList factorize2(const CanonicalForm&, const
Variable&, const CanonicalForm&)':
factor/Factor.cc:74: error: 'rootOf' was not declared in this scope
factor/Factor.cc: In function 'int specializePoly(const CanonicalForm&,
Variable&, int, SFormList&, int, int)':
factor/Factor.cc:448: error: 'rootOf' was not declared in this scope
factor/Factor.cc: In function 'CFFList Factorize(const CanonicalForm&, const
CanonicalForm&, int)':
factor/Factor.cc:1009: error: 'rootOf' was not declared in this scope
factor/Factor.cc: At global scope:
factor/Factor.cc:3: warning: 'rcsid' defined but not used
factor/Factor.cc:4: warning: 'errmsg' defined but not used
make: *** [OPTOBJ/Factor.o] Error 1
make: *** Waiting for unfinished jobs....
error: Bad exit status from /var/tmp/rpm-tmp.88629 (%build)
Comment 1 Michael Schwendt 2006-03-28 05:21:18 EST
Created attachment 126890 [details]
patch against factory 2.0.5

Yes, due to GCC 4.10, but inside factory-2.0.5, and the attached
patch only fixes a few of these bugs (enough to build libfac).
Comment 2 Rex Dieter 2006-03-28 08:25:46 EST
Thanks Michael... I'll go give it a whirl in mock and see how much further we
get... (-:

Note You need to log in before you can comment on or make changes to this bug.