Bug 1832581 - Unable to list/enable EUS repositories on the RHEL clients registered in the satellite server with org_environment contentAccessMode
Summary: Unable to list/enable EUS repositories on the RHEL clients registered in the ...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Satellite
Classification: Red Hat
Component: Candlepin
Version: 6.6.0
Hardware: Unspecified
OS: Linux
high
unspecified vote
Target Milestone: 6.7.2
Assignee: William Poteat
QA Contact: Lai
URL:
Whiteboard:
: 1862245 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-05-06 20:48 UTC by Mike McCune
Modified: 2021-05-18 08:52 UTC (History)
24 users (show)

Fixed In Version: candlepin-2.9.26-1
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1796697
Environment:
Last Closed: 2020-07-30 20:21:13 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Knowledge Base (Solution) 4862361 0 None None None 2020-08-07 14:07:51 UTC
Red Hat Product Errata RHBA-2020:3255 0 None None None 2020-07-30 20:21:26 UTC

Description Mike McCune 2020-05-06 20:48:55 UTC
+++ This bug was initially created as a clone of Bug #1796697 +++

Description of problem:

Unable to list/enable EUS repositories on the RHEL client registered in the satellite server with org_environment contentAccessMode 

Version-Release number of selected component (if applicable):

satellite-6.6.1-1.el7sat.noarch

How reproducible:

100%


Steps to Reproduce:

1. Uploaded a manifest to the satellite with content access mode set to Organization environment access.
2. Enabled and synced the EUS repositories on the satellite server.
3. Registered a host to the satellite server.

~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
[root@vm250-238 entitlement]# subscription-manager status
+-------------------------------------------+
   System Status Details
+-------------------------------------------+
Overall Status: Disabled
Content Access Mode is set to Organization/Environment Access. This host has access to content, regardless of subscription status.

System Purpose Status: Disabled
~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
4. subscription-manager repos --list don't list any repositories.

~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
[root@vm250-238 entitlement]# subscription-manager repos --list
This system has no repositories available through subscriptions.
~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
[root@vm250-238 entitlement]# rct cat-cert 8371081700132599352.pem

+-------------------------------------------+
Entitlement Certificate
+-------------------------------------------+

Certificate:
Path: 8371081700132599352.pem
Version: 3.3
Serial: 8371081700132599352
Start Date: 2020-01-30 23:38:35+00:00
End Date: 2021-01-30 23:38:35+00:00
Pool ID: Not Available

Subject:
CN: 1c3ba3dd-5677-44ab-9c5f-20042ca15d13
O: RedHat
OU: Library

Issuer:
C: US
CN: dhcp130-175.gsslab.pnq2.redhat.com
L: Raleigh
O: Katello
OU: SomeOrgUnit
ST: North Carolina

Product:
ID: content_access
Name:  Content Access
Version: 
Arch: 
Tags: 
Brand Type: 
Brand Name: 

Order:
Name: Content Access
Number: 
SKU: content_access
Contract: 
Account: 
Service Type: 
Roles: 
Service Level: 
Usage: 
Add-ons: 
Quantity: 
Quantity Used: 1
Socket Limit: 
RAM Limit: 
Core Limit: 
Virt Only: False
Stacking ID: 
Warning Period: 0
Provides Management: False

Authorized Content URLs:
/RedHat/Library

Content:
Type: yum
Name: Red Hat Enterprise Linux 8 for x86_64 - AppStream (RPMs)
Label: rhel-8-for-x86_64-appstream-rpms
Vendor: Red Hat
URL: /RedHat/Library/content/dist/rhel8/$releasever/x86_64/appstream/os
GPG: file:///etc/pki/rpm-gpg/RPM-GPG-KEY-redhat-release
Enabled: False
Expires: 1
Required Tags: rhel-8-x86_64
Arches: x86_64
========================================================================

Actual results:
+-------------------------------------------+
This system has no repositories available through subscriptions.
+-------------------------------------------+
Non-EUS repositories enabled and synced on the satellite server are getting listed on the client host. The issue seems to be only with EUS repositories.


Expected results:

Should list all the repositories enabled and sync on the satellite server on the client host for a particular RHEL release.

Comment 4 Mike McCune 2020-06-01 16:27:39 UTC
This did not make it into 6.7.1 and is being moved to 6.7.2 or an async release.

Comment 5 Mike McCune 2020-06-01 16:28:01 UTC
We will be attaching a HOTFIX Candlepin build to this as soon as available.

Comment 7 Mike McCune 2020-06-15 16:25:24 UTC
*** Satellite 6.7.0 and 6.7.1 Hotfix Available ***


1) Download http://people.redhat.com/~mmccune/hotfix/candlepin-2.9.26-1.tar to your Satellite

wget http://people.redhat.com/~mmccune/hotfix/candlepin-2.9.26-1.tar

2) extract hotfix packages

tar xvf candlepin-2.9.26-1.tar

3) stop services:

satellite-maintain service stop

4) Install:

rpm -Uvh candlepin-2.9.26-1.el7sat.noarch.rpm candlepin-selinux-2.9.26-1.el7sat.noarch.rpm 

5) restart:

satellite-maintain service start

6) resume operations

Comment 16 errata-xmlrpc 2020-07-30 20:21:13 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:3255

Comment 17 James Jeffers 2020-08-07 14:07:52 UTC
*** Bug 1862245 has been marked as a duplicate of this bug. ***

Comment 18 William Poteat 2021-04-14 13:33:46 UTC
removing my needinfo


Note You need to log in before you can comment on or make changes to this bug.