Bug 1832609 - Icons from templates not properly shown in the catalog list when the icon is a font icon
Summary: Icons from templates not properly shown in the catalog list when the icon is ...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Dev Console
Version: 4.4
Hardware: Unspecified
OS: Unspecified
unspecified
low
Target Milestone: ---
: 4.5.0
Assignee: Christoph Jerolimov
QA Contact: Gajanan More
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-05-06 21:35 UTC by Sergio G.
Modified: 2020-07-13 17:35 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-07-13 17:35:31 UTC
Target Upstream Version:


Attachments (Terms of Use)
screenshots (151.26 KB, application/zip)
2020-05-06 21:35 UTC, Sergio G.
no flags Details
3 Templates with and without icons to test different scenarios (1.59 KB, application/zip)
2020-05-13 13:23 UTC, Christoph Jerolimov
no flags Details
Icons from templates properly shown in the catalog list when the icon is a font icon-1 (27.59 KB, image/png)
2020-06-01 09:35 UTC, spathak@redhat.com
no flags Details
Icons from templates properly shown in the catalog list when the icon is a font icon-2 (78.56 KB, image/png)
2020-06-01 09:35 UTC, spathak@redhat.com
no flags Details
Icons from templates properly shown in the catalog list when the icon is a font icon-3 (34.29 KB, image/png)
2020-06-01 09:36 UTC, spathak@redhat.com
no flags Details
Icons from templates properly shown in the catalog list when the icon is a font icon-4 (21.45 KB, image/png)
2020-06-01 09:36 UTC, spathak@redhat.com
no flags Details
Icons from templates properly shown in the catalog list when the icon is a font icon-5 (24.07 KB, image/png)
2020-06-01 09:37 UTC, spathak@redhat.com
no flags Details
Icons from templates properly shown in the catalog list when the icon is a font icon-6 (24.53 KB, image/png)
2020-06-01 09:38 UTC, spathak@redhat.com
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Github openshift console pull 5426 0 None closed Bug 1832609: Use the same icon in the template catalog list and the detail overlay 2020-07-29 07:32:05 UTC
Red Hat Product Errata RHBA-2020:2409 0 None None None 2020-07-13 17:35:48 UTC

Description Sergio G. 2020-05-06 21:35:50 UTC
Created attachment 1685959 [details]
screenshots

Description of problem:
Icons from templates not properly shown in the catalog list (ie. after a search) when the iconClass is a font icon and not an image.

The icon is properly shown in other parts of the UI. See attachments.


Version-Release number of selected component (if applicable):
4.x including 4.4


How reproducible:
Always


Steps to Reproduce:
1. Create a template with a custom icon: metadata.annotations.iconClass = "fa fa-fill-drip"

2. Find the template in the catalog and see how the icon is not shown

3. Click on the template to see the details and see how the icon is properly shown

4. Click on "instantiate template" and see how the icon is properly shown in the next screen


Actual results:
The icon is not shown in the template list, only after clicking in the template to see the details or instantiating it.



Expected results:
The icon should be properly shown in all the pages.

Comment 2 Christoph Jerolimov 2020-05-13 13:23:58 UTC
Created attachment 1688022 [details]
3 Templates with and without icons to test different scenarios

Comment 6 spathak@redhat.com 2020-06-01 09:35:17 UTC
Created attachment 1694052 [details]
Icons from templates properly shown in the catalog list when the icon is a font icon-1

Comment 7 spathak@redhat.com 2020-06-01 09:35:58 UTC
Created attachment 1694053 [details]
Icons from templates properly shown in the catalog list when the icon is a font icon-2

Comment 8 spathak@redhat.com 2020-06-01 09:36:29 UTC
Created attachment 1694054 [details]
Icons from templates properly shown in the catalog list when the icon is a font icon-3

Comment 9 spathak@redhat.com 2020-06-01 09:36:56 UTC
Created attachment 1694055 [details]
Icons from templates properly shown in the catalog list when the icon is a font icon-4

Comment 10 spathak@redhat.com 2020-06-01 09:37:39 UTC
Created attachment 1694056 [details]
Icons from templates properly shown in the catalog list when the icon is a font icon-5

Comment 11 spathak@redhat.com 2020-06-01 09:38:15 UTC
Created attachment 1694058 [details]
Icons from templates properly shown in the catalog list when the icon is a font icon-6

Comment 12 spathak@redhat.com 2020-06-01 09:39:03 UTC
Verified on build version: 4.5.0-0.ci-2020-05-22-084435
Browser version: Firefox 73

Comment 13 errata-xmlrpc 2020-07-13 17:35:31 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:2409


Note You need to log in before you can comment on or make changes to this bug.