Bug 183263 - s-c-s modules for ISA cards not loaded even when detected OK
s-c-s modules for ISA cards not loaded even when detected OK
Status: CLOSED DUPLICATE of bug 178998
Product: Fedora
Classification: Fedora
Component: system-config-soundcard (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Martin Stransky
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-02-27 15:18 EST by Jon Burgess
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-03-01 17:07:01 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jon Burgess 2006-02-27 15:18:51 EST
Description of problem:
My old test machine has an ISA CS4236 chip. I installed FC5t3 on it and the
soundcard was detected OK, but none of the audio apps worked.

Version-Release number of selected component (if applicable):
system-config-soundcard-1.2.16-1

How reproducible:
Every time

Steps to Reproduce:
1. Find old machine with an ISA soundcard
2. Run system-config-soundcard which detects OK and writes /etc/modprobe.conf
3. Reboot system
4. Login
5. Start totem or other multimedia app.
  
Actual results:
no sound. /dev/dsp /dev/snd/* missing
All multimedia apps broken.
Gnome volume control reports error.

Expected results:
/dev/dsp, /dev/snd device nodes present. snd-cs4236 module loaded

Additional info:
/etc/modprobe.conf:
alias snd-card-0 snd-cs4236
options snd-card-0 index=0
options snd-cs4236 index=0
remove snd-cs4236 { /usr/sbin/alsactl store 0 >/dev/null 2>&1 || : ; };
/sbin/modprobe -r --ignore-remove snd-cs4236


I think what is missing is that there is nothing in the system which will
effectively 'modprobe snd-card-0'. In the pre-udev days I think the kernel
module loader whuld trigger this when an app tried to open the audio device
nodes, but the nodes are not present any longer until the modules are loaded.

IIRC - it works OK for PCI soundcards because hotplug loads drivers for every
PCI device which matches a driver in the module.pcimap.

I can fix it by echo "modprobe snd-card-0" >> /etc/rc.local, but that doesn't
seem to be the correct solution. I'm not sure this is strictly a s-c-s bug, but
this seems to be the main place to report issues with the audio system.

I think the modules need to be loaded during system startup so that the the
ownership of the audio device nodes can be set correctly during user login.
Comment 1 Takaki Hiroshi 2006-02-27 15:48:15 EST
This bug seems like a duplicate of #178998.
Comment 2 Jon Burgess 2006-02-27 19:06:24 EST
yes it looks a lot like bug 178998. Having dug into udev a little it seems this
is now responsible for loading the driver via udev_run_hotplugd. Any clues on
how to debug udev hotplug?
Comment 3 Jon Burgess 2006-03-01 17:07:01 EST

*** This bug has been marked as a duplicate of 178998 ***

Note You need to log in before you can comment on or make changes to this bug.