Bug 1832808 - value for node's Zone is wrong on administrator console
Summary: value for node's Zone is wrong on administrator console
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Management Console
Version: 4.5
Hardware: Unspecified
OS: Unspecified
low
low
Target Milestone: ---
: 4.5.0
Assignee: Rastislav Wagner
QA Contact: Yadan Pei
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-05-07 10:16 UTC by Junqi Zhao
Modified: 2020-07-13 17:36 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-07-13 17:35:55 UTC
Target Upstream Version:


Attachments (Terms of Use)
value for node's Zone is wrong on administrator console (143.13 KB, image/png)
2020-05-07 10:16 UTC, Junqi Zhao
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Github openshift console pull 5375 0 None closed Bug 1832808: Fix zone lookup for Node Overview Details card 2020-08-26 05:39:09 UTC
Red Hat Product Errata RHBA-2020:2409 0 None None None 2020-07-13 17:36:12 UTC

Description Junqi Zhao 2020-05-07 10:16:29 UTC
Created attachment 1686128 [details]
value for node's Zone is wrong on administrator console

Description of problem:
cluster-admin user, go to "Compute -> Node" on administrator console, take one node as example, the zone is "ap-south-1a", but from the picture, it is "ap-south-1"
# oc get node --show-labels | grep "ip-10-0-136-178.ap-south-1.compute.internal"
ip-10-0-136-178.ap-south-1.compute.internal   Ready    worker   10h   v1.18.0-rc.1   beta.kubernetes.io/arch=amd64,beta.kubernetes.io/instance-type=m5.xlarge,beta.kubernetes.io/os=linux,failure-domain.beta.kubernetes.io/region=ap-south-1,failure-domain.beta.kubernetes.io/zone=ap-south-1a,kubernetes.io/arch=amd64,kubernetes.io/hostname=ip-10-0-136-178,kubernetes.io/os=linux,node-role.kubernetes.io/worker=,node.kubernetes.io/instance-type=m5.xlarge,node.openshift.io/os_id=rhcos,topology.kubernetes.io/region=ap-south-1,topology.kubernetes.io/zone=ap-south-1a

Version-Release number of selected component (if applicable):
4.5.0-0.nightly-2020-05-06-003431

How reproducible:
always

Steps to Reproduce:
1. See the description
2.
3.

Actual results:
zone is not right

Expected results:
no error

Additional info:

Comment 1 Robb Hamilton 2020-05-07 18:11:33 UTC
Reassignign to Rastislav since he delivered this functionality.  I think this is a labeling issue as https://github.com/openshift/console/blob/master/frontend/packages/console-app/src/components/nodes/node-dashboard/DetailsCard.tsx#L21 explicitly points at `topology.kubernetes.io/region` and not `topology.kubernetes.io/zone`.

Comment 4 Junqi Zhao 2020-05-13 07:10:02 UTC
Tested with 4.5.0-0.nightly-2020-05-12-191228, value for Zone on "Compute -> Node" is the same with node's label "topology.kubernetes.io/zone"

Comment 5 errata-xmlrpc 2020-07-13 17:35:55 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:2409


Note You need to log in before you can comment on or make changes to this bug.