Bug 1832819 - [4.5] "Error on ingesting results from rule evaluation with different value but same timestamp" warn info in prometheus container
Summary: [4.5] "Error on ingesting results from rule evaluation with different value b...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Monitoring
Version: 4.5
Hardware: Unspecified
OS: Unspecified
low
low
Target Milestone: ---
: 4.5.0
Assignee: Simon Pasquier
QA Contact: Junqi Zhao
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-05-07 10:24 UTC by Junqi Zhao
Modified: 2020-07-13 17:36 UTC (History)
9 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-07-13 17:35:55 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github kubernetes-monitoring kubernetes-mixin pull 420 0 None closed Add 'factor' label to KubeAPIErrorBudgetBurn alerts 2021-02-19 13:35:59 UTC
Github openshift cluster-monitoring-operator pull 791 0 None closed Bug 1832819: bump kubernetes-monitoring/kubernetes-mixin 2021-02-19 13:35:59 UTC
Red Hat Product Errata RHBA-2020:2409 0 None None None 2020-07-13 17:36:12 UTC

Description Junqi Zhao 2020-05-07 10:24:29 UTC
Description of problem:
# oc -n openshift-monitoring logs prometheus-k8s-0 -c prometheus | grep "Error on ingesting results from rule evaluation with different value but same timestamp"
level=warn ts=2020-05-07T05:27:18.513Z caller=manager.go:566 component="rule manager" group=kube-apiserver-slos msg="Error on ingesting results from rule evaluation with different value but same timestamp" numDropped=1
level=warn ts=2020-05-07T05:32:18.513Z caller=manager.go:566 component="rule manager" group=kube-apiserver-slos msg="Error on ingesting results from rule evaluation with different value but same timestamp" numDropped=1
level=warn ts=2020-05-07T06:25:18.514Z caller=manager.go:566 component="rule manager" group=kube-apiserver-slos msg="Error on ingesting results from rule evaluation with different value but same timestamp" numDropped=1
level=warn ts=2020-05-07T07:27:18.513Z caller=manager.go:566 component="rule manager" group=kube-apiserver-slos msg="Error on ingesting results from rule evaluation with different value but same timestamp" numDropped=1

 oc -n openshift-monitoring logs prometheus-k8s-1 -c prometheus | grep "Error on ingesting results from rule evaluation with different value but same timestamp"
level=warn ts=2020-05-07T05:27:18.513Z caller=manager.go:566 component="rule manager" group=kube-apiserver-slos msg="Error on ingesting results from rule evaluation with different value but same timestamp" numDropped=1
level=warn ts=2020-05-07T05:32:48.513Z caller=manager.go:566 component="rule manager" group=kube-apiserver-slos msg="Error on ingesting results from rule evaluation with different value but same timestamp" numDropped=1
level=warn ts=2020-05-07T06:25:18.514Z caller=manager.go:566 component="rule manager" group=kube-apiserver-slos msg="Error on ingesting results from rule evaluation with different value but same timestamp" numDropped=1
level=warn ts=2020-05-07T07:27:48.522Z caller=manager.go:566 component="rule manager" group=kube-apiserver-slos msg="Error on ingesting results from rule evaluation with different value but same timestamp" numDropped=1

these warn info does not affect the function

Version-Release number of selected component (if applicable):
4.5.0-0.nightly-2020-05-06-003431

How reproducible:
always

Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 Junqi Zhao 2020-05-07 10:39:05 UTC
4.5.0-0.nightly-2020-05-06-003431
node_exporter v0.18.1

Comment 2 Junqi Zhao 2020-05-07 10:40:27 UTC
(In reply to Junqi Zhao from comment #1)
> node_exporter v0.18.1

prometheus 2.15.2

Comment 7 Junqi Zhao 2020-05-27 02:15:35 UTC
no issue with 4.5.0-0.nightly-2020-05-26-193830

Comment 8 errata-xmlrpc 2020-07-13 17:35:55 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:2409


Note You need to log in before you can comment on or make changes to this bug.