Bug 183283 - system hangs with Intel 915 motherboard video
system hangs with Intel 915 motherboard video
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: xorg-x11 (Show other bugs)
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: X/OpenGL Maintenance List
Depends On:
  Show dependency treegraph
Reported: 2006-02-27 16:58 EST by Michael
Modified: 2007-11-30 17:07 EST (History)
1 user (show)

See Also:
Fixed In Version: RHEL4 U3
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2006-03-09 01:26:19 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Michael 2006-02-27 16:58:28 EST
Description of problem:

I tagged this as xorg-x11 ... not sure that is correct ... it is some type of
video driver problem. 

Graphical installation proceeds fine. System seems to hang when trying to
display graphical login or when trying to switch from graphical mode back to
text mode (during system shutdown). 

Version-Release number of selected component (if applicable):

RHEL ES 4 update 2

How reproducible: Always

Steps to Reproduce:
1. Install RHEL4 ES update 2 on Dell Dimension 4700 with built-in Intel 915
video on the motherboard, with 8 Mb of built-in ram dedicated to the video
2. Observe that the graphical installation proceeds fine, without any problems
3. Go through first-boot ...
4. Observe that the video card is correctly identified as Intel 915
5. Observe that the video monitor is UNKNOWN
6. Leave settings at 800x600, or select correct monitor and pick another resolution
7. At the end of first-boot stuff, observe that graphical login screen never
appears, regardless of how long you wait. 
8. power off system
9. restart
10. observe that graphical login screen never appears
11. power off system
12. restart in single user mode
13. init 3
14. login
16. Observe that graphical mode works OK
16. Actions -> Logout -> Shutdown
17. Observe that screen goes blank and system hangs, never shutting down
18. power off system. 
19. restart in single user mode
20. init 5
21. observe that graphical login appears
22. log in successfully
23. Actions -> Logout -> Shutdown
24. Observe that screen goes blank and system hangs, never shutting down

Actual results:

System hangs with video driver problem. 

Expected results:

Video system works OK

Additional info:

This motherboard has PCI Express, no AGP. I do not have a PCI express video card. 

I plugged in an old Matrox Millennium PCI video card. Reinstalled rhel4u2 and
everything worked fine. 

I am successfully running Fedora Core 4 on this hardware using the built-in
Intel 915 video. Have not had any problems at all. And I think that I ran Fedora
Core 3 on this hardware too.
Comment 1 Olivier Baudron 2006-03-02 16:08:59 EST
What is your xorg-x11 version on rhel4u2?
Comment 2 Michael 2006-03-02 17:34:01 EST
This was an install right off the the CDs. No updates were run. 

'rpm-qa' | grep xorg' reports

Comment 3 Olivier Baudron 2006-03-03 04:58:08 EST
It is curious, because xorg-x11-6.8.2-1.EL.13.20 is very close to the FC4
updated version xorg-x11-6.8.2-37.FC4.49.2. 

Unless you use a non-updated version of xorg-x11 under FC4?
Comment 4 Mike A. Harris 2006-03-08 03:15:28 EST
> It is curious, because xorg-x11-6.8.2-1.EL.13.20 is very close to the FC4
> updated version xorg-x11-6.8.2-37.FC4.49.2. 

While it is true that FC4 and RHEL4 xorg packaging are fairly similar, they
are maintained separately from each other and have diverged a fair bit if
you compare the latest RHEL4 xorg-x11 to the latest FC4 one.

The RHEL kernel is also very different from the FC4 one, and in the case of
lockups, shouldn't be ruled out.
Comment 5 Mike A. Harris 2006-03-08 03:17:34 EST
Please update to RHEL4 U3, and update the report to indicate if this problem
still exists in U3 with the i8xx hardware.

If the problem does still exist, please run: system-config-display --reconfig

Start up the X server, and please attach the X server log file and config file
from the attempt as individual uncompressed bugzilla file attachments using
the link below.

Comment 6 Michael 2006-03-08 11:42:07 EST
Works fine with RHEL 4 Update 3

I consider this closed ... but will let you officially close it. 
Comment 7 Mike A. Harris 2006-03-09 01:26:19 EST
Ok, thanks for the quick update!

Setting status to "ERRATA"

Note You need to log in before you can comment on or make changes to this bug.