Bug 1832832 - Disk extension fails due to misuse of oVirt api
Summary: Disk extension fails due to misuse of oVirt api
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Cloud Compute
Version: 4.5
Hardware: Unspecified
OS: Unspecified
urgent
urgent
Target Milestone: ---
: 4.5.0
Assignee: Roy Golan
QA Contact: Jan Zmeskal
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-05-07 10:58 UTC by Roy Golan
Modified: 2020-07-13 17:36 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-07-13 17:35:55 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift cluster-api-provider-ovirt pull 47 0 None closed Bug 1832832: Fix disk extension 2020-08-01 00:00:35 UTC
Red Hat Product Errata RHBA-2020:2409 0 None None None 2020-07-13 17:36:12 UTC

Description Roy Golan 2020-05-07 10:58:08 UTC
Description of problem:

Disk extension fails due to misuse of the API. 

Version-Release number of selected component (if applicable):
all

How reproducible:
100%

Steps to Reproduce:
1.edit the machineset like so (stripping unrelated parts)

spec:
  template:
    spec:
      providerSpec:
        value:
          os_disk:
            size_gb: 18

Note that the value 18 must be greater than the current disk size, which is 16 (at the moment, will change in the future)


2. delete a machine, let the controller recreate it. It will not boot
and the disk size will remain 16

Expected results:
VM boots and the disk extends to 18GB

Comment 4 Jan Zmeskal 2020-05-19 09:11:14 UTC
Verified on cluster version: 4.5.0-0.nightly-2020-05-18-043243
RHV: rhvm-4.3.10.3-0.1.master.el7.noarch

Verification steps:
1. Have a deployed OCP4.5 cluster
2. Edit worker MachineSet and increase disk size from my original value (32 GB) to a new value (36 GB)
3. Scale the MachineSet down
4. Scela the MachineSet up
5. Make sure that the newly created VM has a disk of 36 GB

Comment 5 errata-xmlrpc 2020-07-13 17:35:55 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:2409


Note You need to log in before you can comment on or make changes to this bug.