Bug 1832933 - Select descriptor is not working on create operand form
Summary: Select descriptor is not working on create operand form
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Management Console
Version: 4.5
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
: 4.4.z
Assignee: Jon Jackson
QA Contact: Yadan Pei
URL:
Whiteboard:
Depends On: 1832927
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-05-07 14:05 UTC by Jon Jackson
Modified: 2020-05-26 16:51 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1832927
Environment:
Last Closed: 2020-05-26 16:50:55 UTC
Target Upstream Version:


Attachments (Terms of Use)
mock CSV with select descriptor (2.15 KB, text/plain)
2020-05-07 14:07 UTC, Jon Jackson
no flags Details
Mock.CRD with 'select' schema property (688 bytes, text/plain)
2020-05-07 14:08 UTC, Jon Jackson
no flags Details
Verification screenshot (106.55 KB, image/png)
2020-05-19 01:52 UTC, XiaochuanWang
no flags Details


Links
System ID Priority Status Summary Last Updated
Github openshift console pull 5338 None closed Bug 1832933: Fix select descriptor 2020-06-18 13:48:08 UTC
Red Hat Product Errata RHBA-2020:2180 None None None 2020-05-26 16:51:13 UTC

Description Jon Jackson 2020-05-07 14:05:05 UTC
+++ This bug was initially created as a clone of Bug #1832927 +++

Description of problem:
A dropdown component should be rendered for fields with 'select' descriptors defined. Instead, a standard text field is being rendered.

Version-Release number of selected component (if applicable):
4.4

How reproducible:
Always

Steps to Reproduce:
1. Create a new project named 'test' 
2. Create csv and crd from provided json attachments (oc create -f crd.json,csv.json)
3. Navigate to Operators. > Installed Operators
4. Select "Mock Select Operator" from the list of installed operators
5. On the details page, under Provided APIs, click "Create Instance" in the Mock Select Resource card.
6. Click "Edit Form" in the top right
7. Look for the "Descriptor Generated Select" field

Actual results:
The field is a standard text input


Expected results:
The field is a dropdown with options "DEBUG",  "INFO", "WARN", "ERROR", and "FATAL"


Additional info:
This bug has already been resolved in 4.5 and is only being created so that a fix can be backported to 4.4.z

--- Additional comment from Jon Jackson on 2020-05-07 10:02:40 EDT ---



--- Additional comment from Jon Jackson on 2020-05-07 10:04:18 EDT ---

Resolved in 4.5 by https://github.com/openshift/console/pull/4944

Comment 1 Jon Jackson 2020-05-07 14:07:37 UTC
Created attachment 1686192 [details]
mock CSV with select descriptor

oc new-project test
oc create -f csv.json

Comment 2 Jon Jackson 2020-05-07 14:08:26 UTC
Created attachment 1686193 [details]
Mock.CRD with 'select' schema property

oc create -f crd.json

Comment 3 Jon Jackson 2020-05-07 19:23:42 UTC
PR is open, waiting for 4.5 fix to be verified.

Comment 6 XiaochuanWang 2020-05-19 01:52:10 UTC
Created attachment 1689726 [details]
Verification screenshot

Comment 7 XiaochuanWang 2020-05-19 01:53:36 UTC
Attached the screenshot, this could be Verified.
Checked on 4.4.0-0.nightly-2020-05-18-014003

Comment 9 errata-xmlrpc 2020-05-26 16:50:55 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:2180


Note You need to log in before you can comment on or make changes to this bug.