Bug 183299 - Automount CD-ROM/DVD-ROM not working in GNOME
Automount CD-ROM/DVD-ROM not working in GNOME
Status: CLOSED INSUFFICIENT_DATA
Product: Fedora
Classification: Fedora
Component: gnome-volume-manager (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: David Zeuthen
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-02-27 19:57 EST by Kurt Heine
Modified: 2013-03-05 22:45 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-10 20:51:58 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kurt Heine 2006-02-27 19:57:59 EST
Description of problem:
When inserting a CD-ROM/DVD-ROM into the drive the device does not mount the
media and displays the following dialog boxes.

The first is a blank box and has an OK button.
The second says "Cannot mount volume"  with "You are not privileged tio moun the
volume 'CDROM'."

If I open a command line an su to root then run the mount command then the
device is mounted and I am able to use it as per normal.

I am using GNOME nad have not tried for KDE.  Also this was a FC4 Upgraded
Personal Desktop installation.

Version-Release number of selected component (if applicable):


How reproducible:
Pop a CD in the device

Steps to Reproduce:
1. Place CD-ROM in drive and wait for it to be automounted.
2.
3.
  
Actual results:
Error message and no mounted device

Expected results:
Mounted device which the user can then access.

Additional info:
Comment 1 Kurt Heine 2006-02-27 20:08:28 EST
I have noticed that if it is a new installation this problem does not exists.
Comment 2 John (J5) Palmieri 2006-02-28 10:18:01 EST
Clean out your /etc/fstab.  Delete all lines with the managed option in it. 
Future versions of the hal package will do this during an upgrade.
Comment 3 Kurt Heine 2006-03-06 20:06:26 EST
I cleaned up /etc/fstab and removed all references to lines with managed option
in there as per above but there are still some 'minor' issues which I get now. 
I have upgraded everything to the latest development 07 March (and rebooted the
system) and I still get the same problem with the dialog boxes appearing.  This
only seems to happen if I click on the CDROM device in the 'Computer' folder on
my dekstop.  If I leave it and let the CD automount work then it mounts the CD
as per normal.

My /etc/fstab file at the moment :
LABEL=/                 /                       ext3    defaults        1 1
LABEL=/boot             /boot                   ext3    defaults        1 2
/dev/devpts             /dev/pts                devpts  gid=5,mode=620  0 0
/dev/shm                /dev/shm                tmpfs   defaults        0 0
/dev/proc               /proc                   proc    defaults        0 0
/dev/sys                /sys                    sysfs   defaults        0 0
Comment 4 Bastien Nocera 2007-02-21 11:26:58 EST
This is a bit dated and not a gnome-media problem. Do you still see the same
problem? Are you using FC6 now?
Comment 5 Matthew Miller 2007-04-06 15:31:41 EDT
Fedora Core 5 and Fedora Core 6 are, as we're sure you've noticed, no longer
test releases. We're cleaning up the bug database and making sure important bug
reports filed against these test releases don't get lost. It would be helpful if
you could test this issue with a released version of Fedora or with the latest
development / test release. Thanks for your help and for your patience.

[This is a bulk message for all open FC5/FC6 test release bugs. I'm adding
myself to the CC list for each bug, so I'll see any comments you make after this
and do my best to make sure every issue gets proper attention.]
Comment 6 petrosyan 2008-03-10 20:51:58 EDT
The information we've requested above is required in order
to review this problem report further and diagnose/fix the
issue if it is still present.  Since there have not been any
updates to the report since thirty (30) days or more since we
requested additional information, we're assuming the problem
is either no longer present in the current Fedora release, or
that there is no longer any interest in tracking the problem.

Setting status to "INSUFFICIENT_DATA".  If you still
experience this problem after updating to our latest Fedora
release and can provide the information previously requested, 
please feel free to reopen the bug report.

Thank you in advance.

Note You need to log in before you can comment on or make changes to this bug.