Bug 1833034 - Incorrect traffic splitting percentage in topology sidebar
Summary: Incorrect traffic splitting percentage in topology sidebar
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Dev Console
Version: 4.5
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: 4.5.0
Assignee: Karthik Jeeyar
QA Contact: Gajanan More
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-05-07 17:10 UTC by Karthik Jeeyar
Modified: 2020-07-13 17:36 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-07-13 17:35:59 UTC
Target Upstream Version:


Attachments (Terms of Use)
traffic sidebar (262.94 KB, image/png)
2020-05-15 10:50 UTC, Gajanan More
no flags Details
traffic modal (233.49 KB, image/png)
2020-05-15 10:50 UTC, Gajanan More
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Github openshift console pull 5342 0 None closed Bug 1833034: fix traffic percentage shown for same revisions in topology sidebar 2020-06-24 02:05:57 UTC
Red Hat Product Errata RHBA-2020:2409 0 None None None 2020-07-13 17:36:19 UTC

Description Karthik Jeeyar 2020-05-07 17:10:45 UTC
Description of problem:

When traffic is split to the same revision but with different tags, the topology and sidebar do not show the correct traffic % to the revision

Version-Release number of selected component (if applicable):
4.5

How reproducible:
Always

Steps to Reproduce:
1. Create a knative service via git import flow
2. In topology page, click on the newly create service
3. In sidebar click on the set traffic distribution
4. Add new row and split the traffic for the same revision in multiple rows
5. click on save

Actual results:
On clicking the service in topology, in the sidebar newly splitted traffic and routes are not been shown.

Expected results:
On clicking the service in topology, in the sidebar newly splitted traffic and routes shoule be shown.

Comment 3 Gajanan More 2020-05-15 10:50:35 UTC
Created attachment 1688889 [details]
traffic sidebar

Comment 4 Gajanan More 2020-05-15 10:50:49 UTC
Created attachment 1688890 [details]
traffic modal

Comment 5 Gajanan More 2020-05-15 10:51:03 UTC
I have validated the bugzilla on:
Build: 4.5.0-0.ci-2020-05-14-224329
Browser: Google Chrome Version 81.0.4044.129
Please have a look at the screenshot shared
Marking this as verified.

Comment 6 errata-xmlrpc 2020-07-13 17:35:59 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:2409


Note You need to log in before you can comment on or make changes to this bug.