Bug 1833065 - EventSource card on Add should show if knativeEventing Crd is present and have EventSources
Summary: EventSource card on Add should show if knativeEventing Crd is present and hav...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Dev Console
Version: 4.5
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: 4.5.0
Assignee: Sahil Budhwar
QA Contact: Gajanan More
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-05-07 18:11 UTC by Sahil Budhwar
Modified: 2020-07-13 17:36 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-07-13 17:35:59 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift console pull 5343 0 None closed Bug 1833065: Fixes: EventSource card on Add should show if knativeEventing Crd is present and have EventSources 2020-06-24 02:05:59 UTC
Red Hat Product Errata RHBA-2020:2409 0 None None None 2020-07-13 17:36:19 UTC

Description Sahil Budhwar 2020-05-07 18:11:03 UTC
Description of problem:
EventSource card on Add should show if knativeEventing Crd is present and have EventSources.

In serverless operator 1.7 GA (Eventing is part of it) we provide CRDs for knativeEventing and then user can create CR for these i.e if created for knativeEventing then all CRDs for various eventSources are available in cluster , it used to happen default with Eventing Operator earlier just with installation.

Prerequisites (if any, like setup, operators/versions):
Install Serverless operator 1.7.

Steps to Reproduce:
1. Check CRDs can't see any of the sources
2. Go to DevConsole -> Add

Actual results: Can see EventSource Card

Expected results: EventSource Card should be shown only if sources are present and user have proper access (Note : create CRs for KnativeEventing and it'll add CRDs for various sources in cluster)

Reproducibility (Always/Intermittent/Only Once): Always

Comment 3 Gajanan More 2020-05-14 12:08:06 UTC
I have validated the bugzilla on
Build: 4.5.0-0.ci-2020-05-13-231257
Browser: Google Chrome Version 81.0.4044.129
Please have a look at the shared screenshots
Marking this as verified.

Comment 4 errata-xmlrpc 2020-07-13 17:35:59 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:2409


Note You need to log in before you can comment on or make changes to this bug.