Bug 183321 - xen kernel in FC5test3 does not boot
Summary: xen kernel in FC5test3 does not boot
Keywords:
Status: CLOSED DUPLICATE of bug 181618
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel-xen
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Juan Quintela
QA Contact: Brian Brock
URL:
Whiteboard:
Depends On:
Blocks: FC5Blocker
TreeView+ depends on / blocked
 
Reported: 2006-02-28 06:38 UTC by Mike A. Harris
Modified: 2007-11-30 22:11 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-02-28 13:35:57 UTC
Type: ---


Attachments (Terms of Use)

Description Mike A. Harris 2006-02-28 06:38:04 UTC
Description of problem:

Installation of FC5 test 3 and selecting Xen support, causes the OS to install
_only_ the Xen kernel, which when the system reboots it totally hangs
with an "Error 13: Invalid or unuseable executable format"

Also, the installation installs only the Xen kernel, without giving any option
to install the normal kernel along with it.  I wanted the normal kernel
installed, with Xen installed too to play with Xen separately.

Instead the OS was unuseable.  Attempts to install a kernel via rescue
methods failed due to SEGV occuring while installing the kernel.  davej
said that should be fixed in the newest rawhide bits however.


Version-Release number of selected component (if applicable):
FC5test3's Xen kernel

How reproducible:
100% or 3 out of 3 Xen installations.

Steps to Reproduce:
1. Install FC5test3 onto fresh partition
2. Choose to include Xen support
3. Accept most defaults, only changing a few desktop related packages in
   custom package selection
  
Actual results:
The only kernel that gets installed is the Xen kernel, which doesn't boot.

Expected results:
- Both Xen and non-Xen kernel gets installed
- Xen kernel boots when selected from grub

Additional info:
I took a digital picture of the exact boot error, if the above paraphrase
is insufficient just let me know and I'll hunt down my camera cable to
attach.

Comment 1 Brian Stein 2006-02-28 13:35:57 UTC

*** This bug has been marked as a duplicate of 181618 ***


Note You need to log in before you can comment on or make changes to this bug.