Bug 1833344 - Helm actions timeout for some charts that take more time
Summary: Helm actions timeout for some charts that take more time
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Dev Console
Version: 4.5
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
: 4.4.z
Assignee: Rohit Rai
QA Contact: Gajanan More
URL:
Whiteboard:
Depends On: 1833343
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-05-08 13:29 UTC by Rohit Rai
Modified: 2020-05-26 16:51 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1833343
Environment:
Last Closed: 2020-05-26 16:50:55 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Github openshift console pull 5362 None closed Bug 1833344: Fix timeout issue in Helm installation 2020-06-18 13:48:40 UTC
Red Hat Product Errata RHBA-2020:2180 None None None 2020-05-26 16:51:13 UTC

Description Rohit Rai 2020-05-08 13:29:04 UTC
+++ This bug was initially created as a clone of Bug #1833343 +++

Description of problem: Helm chart installation takes more time than usual which is why the fetch request timeouts. We increased timeout to 60s in 4.5 but for 4.4 the chart installation consistently fails for IBM charts.

Prerequisites (if any, like setup, operators/versions):

Steps to Reproduce:
1. In 4.4 cluster, go to helm catalog.
2. Try to install IBM charts

Actual results:
Request Times out error on install form.

Expected results:
Request should not timeout.

Reproducibility (Always/Intermittent/Only Once):
Intermittent

Comment 3 Gajanan More 2020-05-19 04:32:50 UTC
I have validated the bugzilla on the
Build: 4.4.0-0.ci-2020-05-18-222957
Browser: Google Chrome Version 81.0.4044.129
Marking this as verified

Comment 5 errata-xmlrpc 2020-05-26 16:50:55 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:2180


Note You need to log in before you can comment on or make changes to this bug.