Bug 1833427 - [4.4] Upgrading from 4.3.18 to 4.4.3 , causing Prometheus creating new PVC
Summary: [4.4] Upgrading from 4.3.18 to 4.4.3 , causing Prometheus creating new PVC
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Monitoring
Version: 4.4
Hardware: All
OS: All
medium
medium
Target Milestone: ---
: 4.4.z
Assignee: Paul Gier
QA Contact: Junqi Zhao
URL:
Whiteboard:
: 1839911 1840820 1846132 1846207 (view as bug list)
Depends On: 1832124 1839911
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-05-08 16:30 UTC by Paul Gier
Modified: 2020-06-23 00:57 UTC (History)
18 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1832124
Environment:
Last Closed: 2020-06-23 00:57:24 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Github openshift prometheus-operator pull 70 None closed Bug 1833427: retain pvc metadata 2020-08-12 07:32:32 UTC
Red Hat Knowledge Base (Solution) 5112351 None None None 2020-05-28 09:52:25 UTC
Red Hat Product Errata RHBA-2020:2580 None None None 2020-06-23 00:57:39 UTC

Comment 1 Junqi Zhao 2020-05-28 01:53:47 UTC
*** Bug 1839911 has been marked as a duplicate of this bug. ***

Comment 2 Pawel Krupa 2020-05-28 09:52:26 UTC
*** Bug 1840820 has been marked as a duplicate of this bug. ***

Comment 3 Junqi Zhao 2020-06-11 06:27:31 UTC
*** Bug 1846207 has been marked as a duplicate of this bug. ***

Comment 4 Lili Cosic 2020-06-11 06:35:01 UTC
*** Bug 1846132 has been marked as a duplicate of this bug. ***

Comment 8 Junqi Zhao 2020-06-15 06:06:22 UTC
Tested with 4.4.0-0.nightly-2020-06-14-142924,set metadata.name for prometheus and alertmanager, 
# oc -n openshift-monitoring get cm/cluster-monitoring-config -oyaml
apiVersion: v1
data:
  config.yaml: |
    prometheusK8s:
      volumeClaimTemplate:
        metadata:
          name: prometheus
...
    alertmanagerMain:
      volumeClaimTemplate:
        metadata:
          name: alertmanager
...
kind: ConfigMap

# oc -n openshift-monitoring get pvc
NAME                               STATUS   VOLUME                                     CAPACITY   ACCESS MODES   STORAGECLASS   AGE
alertmanager-alertmanager-main-0   Bound    pvc-0e5cd972-59f2-40e5-aeb9-603a10b0cc09   4Gi        RWO            gp2            35m
alertmanager-alertmanager-main-1   Bound    pvc-db97f7ee-779c-4531-ada1-ee5a7ad13051   4Gi        RWO            gp2            35m
alertmanager-alertmanager-main-2   Bound    pvc-2a2c0f76-d6ee-41f6-899f-7b25497e1b09   4Gi        RWO            gp2            35m
prometheus-prometheus-k8s-0        Bound    pvc-e79ff754-bbf0-42c8-bb81-99a1d4099c9a   10Gi       RWO            gp2            35m
prometheus-prometheus-k8s-1        Bound    pvc-77207540-19cc-402e-b189-050f2532be3c   10Gi       RWO            gp2            35m

# oc -n openshift-monitoring get sts/alertmanager-main -oyaml
...
  volumeClaimTemplates:
  - metadata:
      creationTimestamp: null
      name: alertmanager
    spec:
      accessModes:
      - ReadWriteOnce
      resources:
        requests:
          storage: 4Gi
      storageClassName: gp2
      volumeMode: Filesystem
...

# oc -n openshift-monitoring get sts/prometheus-k8s -oyaml
...
  volumeClaimTemplates:
  - metadata:
      creationTimestamp: null
      name: prometheus
    spec:
      accessModes:
      - ReadWriteOnce
      resources:
        requests:
          storage: 10Gi
      storageClassName: gp2
      volumeMode: Filesystem
...

Comment 10 errata-xmlrpc 2020-06-23 00:57:24 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:2580


Note You need to log in before you can comment on or make changes to this bug.