Bug 1833483 - Customizations to ignition config files not persisting to bare metal nodes
Summary: Customizations to ignition config files not persisting to bare metal nodes
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Installer
Version: 4.5
Hardware: Unspecified
OS: Unspecified
urgent
urgent
Target Milestone: ---
: 4.5.0
Assignee: Steven Hardy
QA Contact: Polina Rabinovich
URL:
Whiteboard:
Depends On:
Blocks: 1834883
TreeView+ depends on / blocked
 
Reported: 2020-05-08 17:50 UTC by Dustin Black
Modified: 2020-07-13 17:37 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
Clone Of:
: 1834883 (view as bug list)
Environment:
Last Closed: 2020-07-13 17:36:32 UTC
Target Upstream Version:


Attachments (Terms of Use)
ifcfg-<ifname> files are present (46.93 KB, image/png)
2020-06-04 11:01 UTC, Polina Rabinovich
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Github openshift installer pull 3589 0 None closed Bug 1833483: Revert "baremetal: send full ignition to masters" 2021-02-06 17:52:39 UTC
Red Hat Product Errata RHBA-2020:2409 0 None None None 2020-07-13 17:37:23 UTC

Comment 4 Steven Hardy 2020-05-13 08:51:05 UTC
Removing https://github.com/openshift/machine-config-operator/issues/1720 from the tracker since it's only tangentially related to this problem.

https://github.com/openshift/installer/pull/3589 resolves this for masters, and https://bugzilla.redhat.com/show_bug.cgi?id=1834883 is a clone of this bz which tracks a similar revert for cluster-api-provider-baremetal (which will be required to fix this interface regression for workers).

We're discussing option of how we can rework things such that we can satisfy the requirement that led to https://github.com/openshift/installer/pull/3589 (ability to put the external nic on a tagged network) without breaking any existing interfaces.

Comment 6 Polina Rabinovich 2020-06-04 11:00:59 UTC
I checked this bug in 4.5.0-0.nightly-2020-06-04-025914 version,ifcfg-<ifname> files are present on the RHCOS filesystem and so the interfaces disabled, problem fixed. 
(I added attachment that prove it)

Comment 7 Polina Rabinovich 2020-06-04 11:01:59 UTC
Created attachment 1695020 [details]
ifcfg-<ifname> files are present

Comment 8 errata-xmlrpc 2020-07-13 17:36:32 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:2409


Note You need to log in before you can comment on or make changes to this bug.