Bug 18336 - avifile apparently miscompiles under new g++
Summary: avifile apparently miscompiles under new g++
Status: CLOSED DEFERRED
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: gcc   
(Show other bugs)
Version: 7.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jakub Jelinek
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-10-04 15:31 UTC by Need Real Name
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-10-06 09:09:30 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Need Real Name 2000-10-04 15:31:26 UTC
The avifile package from http://divx.euro.ru/ (and repackaging of the
library from http://Xtheater.sourceforge.net/downloads/) Compiles fine, but
at runtime, locks up when trying to do playback.  Package workes fine under
all other Configurations except Redhat 7, including priror Redhat versions,
I assume the problem is in g++ compiled code, but am not sure.

Comment 1 Jakub Jelinek 2000-10-06 09:09:24 UTC
Can you please try building it with -O0 instead of -O2/3 what is used in the
package? That would tell if it is an optimization thing, or either bug in the
frontend or even bug in avifile itself which could be not proper C++.
BTW: What exact options/input (minimal if possible) can be used to reproduce
it?


Note You need to log in before you can comment on or make changes to this bug.