Bug 183360 - beagle-crawl-system
Summary: beagle-crawl-system
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: beagle   
(Show other bugs)
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Alexander Larsson
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: FC5Blocker
TreeView+ depends on / blocked
 
Reported: 2006-02-28 16:53 UTC by Felipe Alfaro Solana
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-03-01 18:21:57 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
invoke beagle using su through /bin/bash shell (621 bytes, patch)
2006-02-28 16:53 UTC, Felipe Alfaro Solana
no flags Details | Diff

Description Felipe Alfaro Solana 2006-02-28 16:53:07 UTC
Description of problem:

beagle-0.2.1-12 includes a cron task intended to crawl contents from several system-wide locations, 
like documentation files and applications shortcuts. This cron task is implemented by the /usr/libexec/
beagle-crawl-system sh script.

Since beagle refuses to run as root, this crawling task is ran as user beagleindex, storing the indexes 
under /var/cache/beagle/indexes. The problem is that beagle-crawl-system runs as root and invokes 
beagle through su to impersonate beagleindex user. However, since the beagleindex user has no shell, 
the invocation to beable fails.

I have attached a patch to impersonate the beagleindex user and invoking beagle using /bin/bash.

Version-Release number of selected component (if applicable):
beagle-0.2.1-12

How reproducible:
Always

Steps to Reproduce:
1. As root, launch /usr/libexec/beagle-crawl-system
2. Nothing will happen
3.
  
Actual results:


Expected results:


Additional info:

Comment 1 Felipe Alfaro Solana 2006-02-28 16:53:07 UTC
Created attachment 125406 [details]
invoke beagle using su through /bin/bash shell

Comment 2 Christopher Aillon 2006-03-01 06:15:07 UTC
Filed http://bugzilla.gnome.org/show_bug.cgi?id=332955

Comment 3 Matthias Clasen 2006-03-01 18:21:57 UTC
fixed in 0.2.1-13


Note You need to log in before you can comment on or make changes to this bug.