Bug 183380 - Document corruption when moving ruby text inside cells of a table
Summary: Document corruption when moving ruby text inside cells of a table
Status: CLOSED UPSTREAM
Alias: None
Product: Fedora
Classification: Fedora
Component: openoffice.org   
(Show other bugs)
Version: 4
Hardware: i386 Linux
medium
high
Target Milestone: ---
Assignee: Caolan McNamara
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-02-28 18:39 UTC by Robert Marcano
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-03-01 09:44:18 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Sample document, using Japanese text with ruby (6.70 KB, application/octet-stream)
2006-02-28 18:40 UTC, Robert Marcano
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
OpenOffice.org 62668 None None None Never

Description Robert Marcano 2006-02-28 18:39:27 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.0.1) Gecko/20060124 Firefox/1.5.0.1

Description of problem:
When text with ruby information is cut from a table cell and pasted on another cell, the document saved is corrupted and can be opened again

Version-Release number of selected component (if applicable):
openoffice.org 2.0.1.1-5.1

How reproducible:
Always

Steps to Reproduce:
1.Open the attached sable document
2.go to A-1 cell (using spreadsheet like coordinates) and select the contents with CTRL+A
3.Cut the selection
4.Move the cursor the the cell below
5.Paste the clipboard contents
6.Save the document and close it
7.Reopen the saved document

Actual Results:  Error dialog with the following information

Read-Error
Format error discovered in the file in sub-document content.xml at 2,5175(row,col).

Expected Results:  the document must open without errors

Additional info:

When moving the D-1 cell the problem does not happens, apparently because the ruby text is not at the start of the selection.

Checking the content.xml file on the indicated coordinates, can be seen that some XML tags are not closed properly

Comment 1 Robert Marcano 2006-02-28 18:40:56 UTC
Created attachment 125409 [details]
Sample document, using Japanese text with ruby

Comment 2 Caolan McNamara 2006-03-01 09:44:18 UTC
oh dear, most horrible. Still in 2.0.2, need to inform upstream about this.
Reported there as http://www.openoffice.org/issues/show_bug.cgi?id=62668


Note You need to log in before you can comment on or make changes to this bug.