Bug 1833877 - Details page has no link to lists page
Summary: Details page has no link to lists page
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Console Kubevirt Plugin
Version: 4.5
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: 4.5.0
Assignee: Yaacov Zamir
QA Contact: Nelly Credi
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-05-11 06:06 UTC by Guohua Ouyang
Modified: 2020-07-13 17:37 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-07-13 17:36:48 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift console pull 5387 0 None closed Bug 1833877: Update virtualization breadcumbs 2020-06-24 02:15:22 UTC
Red Hat Product Errata RHBA-2020:2409 0 None None None 2020-07-13 17:37:26 UTC

Description Guohua Ouyang 2020-05-11 06:06:48 UTC
Description of problem:
On details page, there is no link to navigate to vm/vmtemplate lists page.

Version-Release number of selected component (if applicable):
4.5.0-0.nightly-2020-05-04-113741

How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 Radim Hrazdil 2020-05-11 11:50:44 UTC
Could you please provide a screenshot? I can see 'Virtualization > vm-example Details' breadcrumb above the VM title

Comment 2 Guohua Ouyang 2020-05-11 12:23:54 UTC
'Virtualization > vm-example Details' should be 'Virtualization > Virtual Machines -> vm-example Details'.
It looks okay for VM, it's more obviously for VM templates.

Comment 3 Yaacov Zamir 2020-05-11 14:49:23 UTC
merged upstream:
https://github.com/openshift/console/pull/5295

P.S.
5295 only fixes the breadcrumbs for templates,

for Templates it is now:
'Virtualization > Teamplates -> vm-template Details'.

for VMs it stay the same:
'Virtualization > vm-example Details'.

Comment 6 Guohua Ouyang 2020-05-14 02:44:31 UTC
verified on 4.5.0-0.nightly-2020-05-12-065413.

Comment 7 errata-xmlrpc 2020-07-13 17:36:48 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:2409


Note You need to log in before you can comment on or make changes to this bug.