Bug 1833909 - FTI: drupal7: drupal7
Summary: FTI: drupal7: drupal7
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: drupal7
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Shawn Iwinski
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: F32FailsToInstall
TreeView+ depends on / blocked
 
Reported: 2020-05-11 06:45 UTC by Igor Raits
Modified: 2020-05-31 15:38 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-05-31 15:38:24 UTC
Type: ---


Attachments (Terms of Use)

Description Igor Raits 2020-05-11 06:45:00 UTC
Hello,

Please note that this comment was generated automatically. If you feel that this output has mistakes, please contact me via email (ignatenkobrain@fedoraproject.org).

Your package (drupal7) Fails To Install in Fedora 32:

can't install drupal7:
  - nothing provides php-recode needed by drupal7-7.69-2.fc32.noarch
  
If you don't react accordingly to the policy for FTBFS/FTI bugs (https://docs.fedoraproject.org/en-US/fesco/Fails_to_build_from_source_Fails_to_install/), your package may be orphaned in 8+ weeks.

P.S. The data was generated solely from koji buildroot, so it might be newer than the latest compose or the content on mirrors.

P.P.S. If this bug has been reported in the middle of upgrading multiple dependent packages, please consider using side tags: https://docs.fedoraproject.org/en-US/rawhide-gating/multi-builds/

Thanks!

Comment 2 Miroslav Suchý 2020-05-19 07:06:53 UTC
Note that php-recode extension has been dropped from F32 version of PHP.

The more verbose log from is:

 Problém 1: package php-recode-7.3.17-1.fc31.x86_64 requires php-common(x86-64) = 7.3.17-1.fc31, but none of the providers can be installed
  - php-common-7.3.17-1.fc31.x86_64 does not belong to a distupgrade repository
  - problem with installed package php-recode-7.3.17-1.fc31.x86_64
 Problém 2: problem with installed package drupal7-feeds-2.0-0.23.beta4.fc31.noarch
  - package drupal7-feeds-2.0-0.24.beta4.fc32.noarch requires drupal7(ctools), but none of the providers can be installed
  - drupal7-feeds-2.0-0.23.beta4.fc31.noarch does not belong to a distupgrade repository
  - drupal7-ctools-1.15-2.fc31.noarch does not belong to a distupgrade repository
 Problém 3: package drupal7-pathauto-1.3-10.fc32.noarch requires drupal7(token), but none of the providers can be installed
  - problem with installed package drupal7-pathauto-1.3-9.fc31.noarch
  - drupal7-token-1.7-6.fc31.noarch does not belong to a distupgrade repository
  - drupal7-pathauto-1.3-9.fc31.noarch does not belong to a distupgrade repository
 Problém 4: package drupal7-i18n-1.26-3.fc32.noarch requires drupal7(variable), but none of the providers can be installed
  - problem with installed package drupal7-i18n-1.26-2.fc31.noarch
  - drupal7-variable-2.5-11.fc31.noarch does not belong to a distupgrade repository
  - drupal7-i18n-1.26-2.fc31.noarch does not belong to a distupgrade repository
 Problém 5: package drupal7-7.69-2.fc32.noarch requires php-recode, but none of the providers can be installed
  - package php-recode-7.3.17-1.fc31.x86_64 requires librecode.so.0()(64bit), but none of the providers can be installed
  - problem with installed package drupal7-7.69-1.fc31.noarch
  - recode-3.6-50.fc31.x86_64 does not belong to a distupgrade repository
  - drupal7-7.69-1.fc31.noarch does not belong to a distupgrade repository
 Problém 6: package drupal7-auto_nodetitle-2.0-0.3.alpha1.fc32.noarch requires drupal7(core), but none of the providers can be installed
  - package drupal7-7.69-1.fc31.noarch requires php-recode, but none of the providers can be installed
  - package drupal7-7.69-2.fc32.noarch requires php-recode, but none of the providers can be installed
  - package php-recode-7.3.17-1.fc31.x86_64 requires php-common(x86-64) = 7.3.17-1.fc31, but none of the providers can be installed
  - package php-pecl-zip-1.18.2-1.fc32.x86_64 requires php(api) = 20190902-64, but none of the providers can be installed
  - package php-pecl-zip-1.18.2-1.fc32.x86_64 requires php(zend-abi) = 20190902-64, but none of the providers can be installed
  - cannot install both php-common-7.4.6-1.fc32.x86_64 and php-common-7.3.17-1.fc31.x86_64
  - cannot install both php-common-7.4.4-1.fc32.x86_64 and php-common-7.3.17-1.fc31.x86_64
  - problem with installed package php-pecl-zip-1.17.2-1.fc31.x86_64
  - php-pecl-zip-1.17.2-1.fc31.x86_64 does not belong to a distupgrade repository
  - problem with installed package drupal7-auto_nodetitle-2.0-0.2.alpha1.fc31.noarch
  - drupal7-auto_nodetitle-2.0-0.2.alpha1.fc31.noarch does not belong to a distupgrade repository
 Problém 7: package drupal7-date-2.10-7.fc32.noarch requires drupal7(core), but none of the providers can be installed
  - package drupal7-7.69-1.fc31.noarch requires php-recode, but none of the providers can be installed
  - package drupal7-7.69-2.fc32.noarch requires php-recode, but none of the providers can be installed
  - package php-recode-7.3.17-1.fc31.x86_64 requires php-common(x86-64) = 7.3.17-1.fc31, but none of the providers can be installed
  - package php-pecl-ssh2-1.2-3.fc32.x86_64 requires php(api) = 20190902-64, but none of the providers can be installed
  - package php-pecl-ssh2-1.2-3.fc32.x86_64 requires php(zend-abi) = 20190902-64, but none of the providers can be installed
  - cannot install both php-common-7.4.6-1.fc32.x86_64 and php-common-7.3.17-1.fc31.x86_64
  - cannot install both php-common-7.4.4-1.fc32.x86_64 and php-common-7.3.17-1.fc31.x86_64
  - problem with installed package php-pecl-ssh2-1.2-1.fc31.x86_64
  - php-pecl-ssh2-1.2-1.fc31.x86_64 does not belong to a distupgrade repository
  - problem with installed package drupal7-date-2.10-6.fc31.noarch
  - drupal7-date-2.10-6.fc31.noarch does not belong to a distupgrade repository
...

The culprit is drupal7 dependency on php-recode.

Comment 3 Shawn Iwinski 2020-05-31 15:38:24 UTC
$ date
Sun 31 May 2020 11:37:11 AM EDT

$ cat /etc/fedora-release 
Fedora release 32 (Thirty Two)

$ dnf install --enablerepo updates-testing  -y drupal7
Last metadata expiration check: 1:50:44 ago on Sun 31 May 2020 09:46:38 AM EDT.
Dependencies resolved.
======================================================================================================================
 Package                    Architecture              Version                        Repository                  Size
======================================================================================================================
Installing:
 drupal7                    noarch                    7.70-1.fc32                    updates                    2.6 M

Transaction Summary
======================================================================================================================
Install  1 Package

Total download size: 2.6 M
Installed size: 12 M
Downloading Packages:
drupal7-7.70-1.fc32.noarch.rpm                                                        5.5 MB/s | 2.6 MB     00:00    
----------------------------------------------------------------------------------------------------------------------
Total                                                                                 4.2 MB/s | 2.6 MB     00:00     
Running transaction check
Transaction check succeeded.
Running transaction test
Transaction test succeeded.
Running transaction
  Preparing        :                                                                                              1/1 
  Installing       : drupal7-7.70-1.fc32.noarch                                                                   1/1 
  Running scriptlet: drupal7-7.70-1.fc32.noarch                                                                   1/1 
  Verifying        : drupal7-7.70-1.fc32.noarch                                                                   1/1 

Installed:
  drupal7-7.70-1.fc32.noarch                                                                                          

Complete!


Note You need to log in before you can comment on or make changes to this bug.