Bug 1834163 - Error "Missing fields in node labels" shows on new affinity pages immediately
Summary: Error "Missing fields in node labels" shows on new affinity pages immediately
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Console Kubevirt Plugin
Version: 4.5
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: 4.5.0
Assignee: Yaacov Zamir
QA Contact: Nelly Credi
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-05-11 08:35 UTC by Guohua Ouyang
Modified: 2020-07-13 17:37 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-07-13 17:36:48 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift console pull 5466 0 None closed Bug 1834163: Don't check for nodes when form is empty or invalid 2020-06-24 02:15:29 UTC
Github openshift console pull 5558 0 None closed Bug 1834163: Don't show error on unedited form 2020-06-24 02:15:30 UTC
Red Hat Product Errata RHBA-2020:2409 0 None None None 2020-07-13 17:37:26 UTC

Description Guohua Ouyang 2020-05-11 08:35:27 UTC
Description of problem:
Open VM affinity page, the warning shows immediately. If there is nothing inputted yet, it should have no warnings. 

Version-Release number of selected component (if applicable):
4.5.0-0.nightly-2020-05-04-113741

How reproducible:
100%

Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 3 Guohua Ouyang 2020-05-21 03:39:45 UTC
It still shows the warning, maybe it should only shows the warning by click "Save Affinity rule" if something is missing.

Comment 4 Yaacov Zamir 2020-05-21 04:54:37 UTC
Changing back to ON_QA because we need to see this warnings while users interact with the form.

> It still shows the warning, maybe it should only shows the warning by click "Save Affinity rule" if something is missing.

It is suppose to show the warning immediately when the user enter a new affinity rule,

we can not want to wait for "save" because it will be saved and user will not see warning, this warnings do not ( and should not ) block you from saving
they are there to help users make good decisions about what rules to write.

Comment 5 Guohua Ouyang 2020-05-21 05:24:41 UTC
Then I think it's a bad design here, a highlight warning on a fresh opened page causes panic.

Comment 6 Guohua Ouyang 2020-05-21 05:35:49 UTC
By removing the key/value box for "Add Expression" can make the warning gone, is it good to do it?

Comment 7 Yaacov Zamir 2020-05-21 08:32:54 UTC
Thanks, fixed the wrong message.

Moving back to assigned

> By removing the key/value box for "Add Expression" can make the warning gone, is it good to do it?

sounds good to me, this it the approach we use in the other modals.

Comment 9 Guohua Ouyang 2020-05-27 08:14:00 UTC
verified on upstream 4.5 branch, commit 88b7689b0fb3dfc557d9e06dc509952b9233661e.

Comment 10 errata-xmlrpc 2020-07-13 17:36:48 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:2409


Note You need to log in before you can comment on or make changes to this bug.