Bug 1834174 - It should not success if there is no source selected on environment page.
Summary: It should not success if there is no source selected on environment page.
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Console Kubevirt Plugin
Version: 4.5
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: 4.5.0
Assignee: Ido Rosenzwig
QA Contact: Radim Hrazdil
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-05-11 08:49 UTC by Guohua Ouyang
Modified: 2020-07-13 17:37 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Cause: Success message appears even if no there was no change Consequence: redundant "success" message Fix: message appear only when there is a successful change Result: no redundant messages
Clone Of:
Environment:
Last Closed: 2020-07-13 17:36:48 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift console pull 5408 0 None closed bug 1834174: Save changes on VM environment tab only on valid changes 2020-06-24 02:15:49 UTC
Red Hat Product Errata RHBA-2020:2409 0 None None None 2020-07-13 17:37:26 UTC

Description Guohua Ouyang 2020-05-11 08:49:54 UTC
Description of problem:
On VM environment page, don't select any source but put a serial number there, save it is successful but nothing is saved. It should not success if there is no source selected.

Version-Release number of selected component (if applicable):
4.5.0-0.nightly-2020-05-04-113741

How reproducible:
100%

Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 3 Radim Hrazdil 2020-05-20 12:40:33 UTC
Verified in console release-4.5 branch commit: 5994c64ee529b650bae348ef78ebc23dca8db5c5
It is not possible to save empty source with specified serial number, because an error is displayed and Save button is disabled when source is empty and serial is non-empty

Comment 4 errata-xmlrpc 2020-07-13 17:36:48 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:2409


Note You need to log in before you can comment on or make changes to this bug.